Support » Plugins » Can’t Upgrade Plugins via Dashboard

  • Hi!
    My site is pretty new, only a few weeks old and I keep getting “this plugin has updates, please update” notices which is fine, however I am unable to update the plugins by simply clicking “upgrade” via the dashboard.
    I constantly get this error
    “Unable to locate WordPress Plugin directory.
    Installation Failed”
    My Plugin directory is not in an unusual spot, I never changed the location from the default.
    /htdocs/wp-content/plugins (I use byethost)
    Why is it unable to find my plugin directory and how do I tell it where to find it if it’s not looking in the right spot?


Viewing 15 replies - 1 through 15 (of 15 total)
  • some hosts do not allow this action from paranoia.
    Ask your host about it.

    There was no any other option. . Or if we neglect that message there was no any problem

    I have exactly the same problem, only here’s thing…

    I run two sites, with the same hosting provider. One site is physically located in South Africa and the other in Germany (due to bandwidth requirements).

    On the one in South Africa, auto-upgrade of plug-ins and WordPress (2.7) works fine, but on the one in Germany, it never has. I am asked for ftp details and when I put them in, it says “Unable to locate WordPress Content directory (wp-content)”

    If this is something the host is doing, what do I need to tell them to make them stop! 🙂 (Or what setting needs to be changed?)


    i have the same. can anybody give any proper solution?

    some hosts do not allow this action from paranoia.
    Ask your host about it.

    That’s nonsense and typical deflection.

    My experience is that some plugins update automatically, and some fail.

    I suspect the success/failure rate of automatic upgrades is directly related to the competence of the plugin designer.

    not only upgrade plugins but also install ones. It’s just impossible to do such tings because i get “unable to locate wordpress content directory”

    Here’s the result of my latest “automatic” plugin upgrade:

    Upgrade Plugin

    Downloading update from

    Unpacking the update

    Could not copy file: /public_html/wp-content/upgrade/sitemap/google-sitemap-generator/documentation.txt

    Plugin upgrade Failed

    This is a serious bug in WordPress’ auto updater. As I *AM* my web hosting company Please answer this users question on how to fix this problem, so that hosting companies who read this can do something to help their WordPress users.

    After some digging a blogger has discovered the weakness in your code on his own and posted about it here

    Obviously moving the home directories for ALL of my users because of a WordPress bug is an unacceptable solution, it would lock them out of access to their server logs and various other directories at the root of their accounts.

    The easy fix is to simply add a path text field where you allow the user to input the folder to his html files… or better still you can just change your code to look for the default folders that apache makes, namely, htdocs and html.

    However, the auto-updater does work on some of our accounts… just not all. As the account setups are the same its very confusing and a shame that WordPress has yet to provide useful error messages to its users or their hosting companies when things break.

    I have had similar problems not with specific plugins btu with specific sites hosted with certain hosting providers, like this one client of mine who hosts with Hetzner. Seems the directory structure or something must be confusing the auto updater. I can’t update any plugin whatsoever.

    i am also having this problem on a fresh install.

    as mentioned above by tenminutes, i came across this discussion of one possible solution. it didn’t however work for me. the newly created ftp user pointing directly to the exact dir folder where the blog resides works just fine through Filezilla, but WordPress still is:

    “Unable to locate WordPress Content directory (wp-content)”

    Thus, i am unable to add plugins, themes, etc.

    and THIS description of an odd fix, of course, if anyone can translate that for me and how i might implement that, i’d give it a whirl.

    i’ve also tried to restore a recent backup from a copy of the blog i have as a WordPress eXtended RSS (WXR) file and i get this error:

    “Sorry, there has been an error.
    Missing a temporary folder.”

    i have a feeling these errors are related and that odd solution notes that “ftp_rawlist requires write access to “/tmp”.”



    I have this problem now too on one out of 15 blogs I’m hosting at the same provider. All other blogs are fine, so it is clearly *not* always a hosting issue. This particular one is a clean upgrade from 2.3 to 2.8, and file-wise there are absolutely no differences.



    Add this to your wp-config.php:

    putenv('TMPDIR=' . ini_get('upload_tmp_dir'));

    (First described by lightwolf, here.)

    Works for me.



    In my case non of the above worked, but what did work was instead of typing in the url in the ftp field, I used the server’s local address: and everything worked like a charm again.

    Hope this helps someone else too 🙂

    In my experience i would say that the ammount of plguins installed matters, the more you have installed the the your blog will slow down and will start to show bugs, errors and stuff.
    I would say to deactive the last plugin you have installed and see from there, if this does not work, keep trying on other plugins, be warned as if you unistall the plugin, it may lose information which you may have input in it.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can’t Upgrade Plugins via Dashboard’ is closed to new replies.