• Resolved Upshift-86

    (@upshift-86)


    I am trying to update xml sitemap, clicked “update sitemap” and old pages are shown – new ones aren’t (I did change a couple of urls and set redirects). I selected restore to default sitemap and nothing.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    Clicking “update” shouldn’t be necessary.
    Make sure you’re using dynamic sitemaps, not static, and clear all server and browser caching.

    Thread Starter Upshift-86

    (@upshift-86)

    Thank you. I do not see dynamic sitemap option with this plugin. I have cleared site cache and browser cache but no change. I input the new urls directly.

    Thread Starter Upshift-86

    (@upshift-86)

    Forget that – it wouldn’t update even after inputting urls. I disabled this function in all-in-one-seo and used “Google XML Sitemaps” and had it working correctly in 2 minutes.

    Michael Torbert

    (@hallsofmontezuma)

    WordPress Virtuoso

    You don’t need to manually input any URLs.
    If you were seeing old pages and not new ones, that either means you’re 1) seeing a cached file from whatever server caching you use b) using a static sitemap or c) there’s an old static sitemap from another plugin interfering or d) doing something wrong in the settings.
    Dynamic sitemaps is the default, so if it wasn’t enabled, you unchecked it.

    The sitemap module works with the defaults out of the box, without any configuration. I’d start by resetting to the defaults, then make sure there’s no physical sitemap.xml file on the server from another plugin.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t update xml sitemap’ is closed to new replies.