Support » Fixing WordPress » can’t update with new editor

  • Resolved Carrie

    (@indigohat)


    If I am using the new editor, I get a message at the top in a red bar that says ‘updating failed’. The classic editor plugin is working for me.

    I did all the troubleshooting steps here (including a complete reinstall, disabling all plugins, all settings checks/resaves and using the twenty nineteen theme). Two things look out of whack :

    • there are many javascript errors in the console view on editor page load. Most were related to /wp-includes/js/dist/vendor/react-dom.js?ver=16.6.3. Most say ‘Warning: Unsafe lifecycle methods were found’.
    • Health Check looks good except PHP version 5.6.40 and The REST API call gave the following unexpected result: (404). The 404 page it displays there is my wordpress 404 page.
    • I also have a custom permalink structure : /%category%/%postname%/. The troubleshooting steps mentioned it. I did resave, per the instructions. I’m not sure what the implication there is but seems worth mentioning.

    I’m in completely uncharted territory at this point. I’d like to get it working because one of my plugins has functionality in blocks that I can’t seem to access without it. Any help appreciated.

    • This topic was modified 1 year, 10 months ago by Carrie. Reason: add more/clarifying details
Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator t-p

    (@t-p)

    Health Check looks good except PHP version 5.6.40 and The REST API call gave the following unexpected result: (404).

    The new Block Editor (Gutenberg) needs the Rest API to function.

    Hence, make sure the Rest API at your site is available. If its disabled by some plugin, etc., try enabling it.

    Thread Starter Carrie

    (@indigohat)

    I have tried disabling all plugins and still no dice. How do I get the rest API issue fixed?

    Moderator t-p

    (@t-p)

    It’s enabled by default.

    So, find out how it got disabled — via a plugin, or via snippet, or via something else?

    Thread Starter Carrie

    (@indigohat)

    I disabled all of my plugins except health check and switched to the twenty nineteen theme. Ran health check again and it still says the rest API gives a 404. I was having the issue updating and posting before I installed health check today, so although I didn’t have visibility into the rest api issue before installing that plugin, I have to assume that plugin isn’t the problem.

    I have completely replaced everything in the wp-admin and wp-includes folders. I don’t have anything custom hardcoded into any of the theme files (I’m using Astra but the twenty nineteen theme I’m testing with is completely uncustomized straight out of the box). To my knowledge, there are no custom pages anywhere in my site structure.

    What else could cause it or what else can I try? Could anything in wp-content be affecting it, without plugins or themes installed? WP files in the root directory?

    Thread Starter Carrie

    (@indigohat)

    Found it! Because absolutely nothing in my WP or theme is hacked/customized or otherwise screwed with, the only thing I could think of that would still affect something’s ability to load would have to be happening before the html was loaded – which sent me digging through my htaccess file.

    There was a holdover 301 redirect in my htaccess file from LONG LONG ago when I changed my root directory from /wp/. I removed that, replaced the wordpress standard htaccess blurb with an updated one from here (there was no change), disabled all plugins and removed everything else from htaccess that was left. Tested and it worked. So then added the wordfence stuff back to htaccess and reenabled plugins. Health check can get to Rest API and editing is working!!! Hooray!

    Thank you for responding. Even without getting the answer, it was a great sanity check and got me going in the right direction!

    Moderator t-p

    (@t-p)

    Glad to know it đŸ™‚

    ¿Como consigo entrar al archivo .htaccess si no tengo acceso por que no tengo “CPANEL”?

    • This reply was modified 1 year, 10 months ago by aldoneri.
    Thread Starter Carrie

    (@indigohat)

    @aldoneri , it’s in the root directory of your website. You can probably find it through whatever file explorer your host gives you access to – otherwise, via FTP.

    • This reply was modified 1 year, 10 months ago by Carrie.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘can’t update with new editor’ is closed to new replies.