[resolved] Can't update to 3.5.2 (11 posts)

  1. RexM
    Posted 3 years ago #

    I've attempted to use the automatic update button to update to 3.5.2. The page flashes pretty quickly, then I'm taken to a page welcoming me to WordPress 3.5.1. In the update section, it's still telling me to update 3.5.2, as if I never even attempted to update.

    I thought that was strange so I went ahead and attempting to manually update, following the Updating WordPress directions. It's still as if I've done nothing, and the 3.5.2 update is out there, waiting for me.

    Some more info, I'm hosting two blogs on this server, and both of them are acting up. I'm using varnish for caching, but I'm still seeing the update messages when hitting nginx directly. I've also disabled cloudflare, just in case that could be an issue.

    To check that I updated the files properly, I compared the md5sum from wp-admin/includes/media.php from the file I downloaded and unzipped and the file in my hosted folder. They both seem to be the same.

    031fa9c0b46f25db32c6368a259fdb4c wp-admin/includes/media.php

    If anyone has any ideas or needs some additional information, please let me know. At this point, I'm at a loss.

    http://rexflex.net/ <-- This is the site I've been working with

  2. Tara
    Volunteer Moderator
    Posted 3 years ago #

    have you contacted and discussed the issue with your hosting provider?

  3. RexM
    Posted 3 years ago #

    Thanks for the response Tara, I should have included it in the original post, but the blogs are running on a VPS at Digital Ocean. I don't think they'll be able to help me debug this issue since it's related to the software and everything on their end is working.

    I hit escape on the automatic update page to keep it from redirecting, this is the output it's giving me. Everything seems to be working fine.

    Downloading update from http://wordpress.org/wordpress-3.5.2-partial-1.zip…
    Unpacking the update…
    Verifying the unpacked files…
    Installing the latest version…
    Upgrading database…
    WordPress updated successfully
    Welcome to WordPress 3.5.2. You will be redirected to the About WordPress screen. If not, click here.

    All of this, and then when it redirects me to the next page, it says "Welcome to WordPress 3.5.1" and I still have the update nag at the top of the dashboard.

  4. Pothi Kalimuthu
    Posted 3 years ago #

    Have you tried restarting the PHP process?

    It could be an issue due to APC or similar opcode cache.

  5. RexM
    Posted 3 years ago #

    Thanks! That did the trick.

    $ /etc/init.d/php5-fpm restart

  6. Pothi Kalimuthu
    Posted 3 years ago #

    Glad to share what I remember doing when I had this issue several weeks back. However, I can't reproduce the issue, since then.

    I understand that your site uses Varnish. But, does it also use W3 Total Cache plugin or any object cache plugin?

    I have seen W3TC / object cache plugins having conflict with this kind of issues.

  7. RexM
    Posted 3 years ago #

    I was using W3 Total Cache, however I updated my plugins immediately before updating WordPress, and started getting 500's on all of my pages. I disabled all my plugins and started enabling them one at a time, until I found out it was W3TC that was causing the issue.

    However, it might be possible that APC was caching W3TC, as well. I did notice the W3TC comments at the end of my html, even after I no longer had W3TC in my plugins folder. I had just dismissed it and decided to figure that out once I figure out how to get WordPress upgraded in case it was an issue with the latest version of W3TC with and older version of WordPress (v3.5.1).

    I'm going to attempt to reinstall W3TC now and see if it works properly.

  8. RexM
    Posted 3 years ago #

    I've installed W3TC and everything seems to be working properly. Very strange issue. Thanks for your help :)

  9. Pothi Kalimuthu
    Posted 3 years ago #

    It is indeed a very strange issue. :) Glad everything works as expected now.

  10. Nick
    Posted 3 years ago #


    Could you describe the steps to restarting the PHP process that solved this?


  11. RexM
    Posted 3 years ago #

    Sure, I ran this command to restart php5-fpm.

    sudo /etc/init.d/php5-fpm restart

Topic Closed

This topic has been closed to new replies.

About this Topic