Support » Plugin: Search & Replace » Can’t update to 3.2.1

  • Resolved balvan64

    (@balvan64)


    Hello,
    even updating manually by replacing the file doesn’t work, it still shows the plugin as 3.2 and says there is an update – 3.2.1

    Also, the plugin does not work, when I try and run a replace I get an error.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Frank

    (@bueltge)

    Do you have a error message?

    An error of type E_ERROR was caused in line 355 of the file /home/knivestst/domains/tst.japanese-knives.co.il/public_html/wp-content/plugins/search-and-replace/inc/Database/Replace.php. Error message: Uncaught Error: Cannot access property started with ‘\0’ in /home/knivestst/domains/tst.japanese-knives.co.il/public_html/wp-content/plugins/search-and-replace/inc/Database/Replace.php:355
    Stack trace:
    #0 /home/knivestst/domains/tst.japanese-knives.co.il/public_html/wp-content/plugins/search-and-replace/inc/Database/Replace.php(345): Inpsyde\SearchReplace\Database\Replace->recursive_unserialize_replace(‘https://www.jap…’, ‘https://tst.jap…’, Object(WC_Product_Simple), false)
    #1 /home/knivestst/domains/tst.japanese-knives.co.il/public_html/wp-content/plugins/search-and-replace/inc/Database/Replace.php(345): Inpsyde\SearchReplace\Database\Replace->recursive_unserialize_replace(‘https://www.jap…’, ‘https://tst.jap…’, Array, false)
    #2 /home/knivestst/domains/tst.japanese-knives.co.il/public_html/wp-content/plugins/search-and-replace/inc/Database/Replace.php(341): Inpsyde\SearchReplace\Database\Replace->recursive_unserialize_replace(‘https://www.jap…’, ‘https://tst.jap…’, Array, false)
    #3 /home/knivest

    Before today it worked great.

    Plugin Author Frank

    (@bueltge)

    I have update the svn on w.org, in a public test it works fine now. I hope also for you.
    The 3.2.1 should now the last stable version for you.

    But you error message is in an other context. If you have this error again after install 3.2.1 please downgrade to 3.2.0 and test this . I mean is not a error from the plugin, more from the space, memory. But a test in 3.2.0 again 3.2.1 would really help.

    **Removed**

    • This reply was modified 4 months, 1 week ago by  balvan64.

    I see you’ve fixed the update issue.
    but the error still persists, I cannot use the plugin, I get the error immediately.

    Can I get the old version again? I’ve been using this plugin daily until today’s update.

    Plugin Author Frank

    (@bueltge)

    Yes, you will find all older versions in the advanced view https://wordpress.org/plugins/search-and-replace/advanced/
    Scroll down, use the select field and choose your version.

    Great, when will a fix be available?

    Let’s open a new tread for this.

    Plugin Author Frank

    (@bueltge)

    Yes, now we have a new thread about the php error to \0

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.