Support » Themes and Templates » Can’t Update Theme/No Update Button

  • I’ve spent 6 hours on this and am going crazy…

    I’ve done several installs. Last one was 2.51 that I did. I go in to edit the theme via the editor (everything else seems to work fine)… I don’t have an *update* button. A friend send me a screen shot of what I should see… this *update* button. I read the codex information… there IS a line there about permissions. I tried some permissions stuff and it just wipes out all my templates. Changing the permissions back doesn’t fix anything. Is there specific information on how to get this working? The exact permission on the exact file/directory? I’m so frustrated….


Viewing 9 replies - 1 through 9 (of 9 total)
  • What specific theme is it? Can you edit any of the other themes (e.g., Classic, Default)? If so, it’s a theme-specific issue (for whatever reason; I cannot imagine). 🙁

    It’s the default theme. I uploaded another theme a few installs ago and didn’t see that “update” button show up there either.

    Thanks Joni 🙂

    It’s gotta be a browser issue. The latest version of WP seems to be almost completely AJAX-dependent, to the point that on the old version of IE6 we use at the office, I cannot edit my WP blog (not that I should be doing that on company time you understand). But it just illustrates that if your browser isn’t up to date, it could be a factor.

    Also, maybe all the JS files didn’t make their way over on upload. Can you check that?

    Ugh… husband went in and in 5 mins fixed it… 666 permission on all the files in the default theme dir. Is that editor a true editor? Should I not be looking at that as a way to edit a theme?

    Let me rephrase (after I thought about it). Is it best to upload my own themes or can I use this editor to tweak one up myself? Husband is under the impression that I should be developing my own themes and uploading them. My mentality is that… if that update button wasn’t there and it wasn’t called a *theme editor* then it wasn’t meant to be.

    Thanks again 🙂

    File permissions are set by you via your FTP client. That’s the only way to do that. You can upload any theme to the theme folder and once permissions are properly set, edit away, whether it’s your own design or someone else’s. That really doesn’t matter. You seemed so certain on the list that it was NOT a file permission issue, that the files were set to 766 (which is what they need to be in order to be editable from within the theme editor console). At least it’s solved.

    And personally. about developing themes, I do that strictly with my HTML editor (EditPlus2) and my CSS editor (TopStyle Pro). I generally just use the theme editor to tweak things. I’ve gotten quite lazy and both my HTML and CSS editors have color coding so that helps me to spot typos. So the answer — for me at least — is that I DEVELOP offline and tweak online.

    What is weird is that I had tried 766… it wiped out all the themes. He reinstalled and set them to 666 and so far I’m puttering along just fine.

    I’ve never used FTP to change file permissions… seems a lot less cumbersome than going in via shell access. I’ll try that next time when I upload another one of these themes.

    Thanks for all the info, it was VERY helpful.

    I’m excited about actually being able to do something now!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t Update Theme/No Update Button’ is closed to new replies.