Support » Plugin: Header and Footer Scripts » Can’t update the plugin to the version

  • Resolved omavaraisuushaaste

    (@omavaraisuushaaste)


    Hello!

    I saw the the new update (version 2.1.1) in the plugin, but my website started saying that I can’t update the plugin as my PHP is not up to date.

    I used “PHP Compatibility Checker” to check if that’s the case as my website doesn’t have that many plugins and all plugins and the theme (Sparkling) came out clear (except Yoast SEO, which was too big, but I doubt that’s the issue as it’s such a widely used plugin) from PHP Compatibility Checker when checking with PHP version 7.0.

    Any ideas what might be wrong and not up-to-date? And is it an issue if I don’t update the plugin or just leave it be as the older version? Thanks!

    Edit: Also, according to bluehost, my website is running PHP version 7.2.7.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Anand Kumar

    (@anand_kumar)

    If you are running PHP v7.2.7 then it is most likely WordPress has some kind of bug. Updates are handled by WordPress core itself. A plugin has nothing to do with it. “PHP Compatibility Checker” only suggests if your site is compatible with PHP v7.x it doesn’t do anything else.

    in the mean time you may check your PHP version by simply installing a plugin like these:
    https://wordpress.org/plugins/debug-info/ OR
    https://wordpress.org/plugins/version-info/

    I will revert the minimum PHP requirement if necessary.

    Thanks for the quick answer! It seems that even though cPanel said it was running 7.2.7., the debug info plugin said it was running 5.6.4 so it was an old one. I contacted the Bluehost service and they helped me to update the site, so the issues seemed to be at my end. I was also able to update the plugin now.

    Thanks for your plugin, otherwise I wouldn’t have noticed that I’m running an old version of PHP!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can’t update the plugin to the version’ is closed to new replies.