WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Can't update roles due to nonce check

[Resolved] Can't update roles due to nonce check

  • Heya, I’m getting the “Wrong nonce. Action prohibitied.” everytime I try to update role editor with the latest version of URE. This is effectively preventing me to do anything with the editor unless I remove the check from the code.

    Also, the editor isn’t refreshing at all, for example, when I try to select roles from the role dropdown, checkboxes aren’t getting updated. I’m getting few JavaScript-errors from the editor page:

    User agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
    Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E)
    Timestamp: Fri, 17 May 2013 10:44:49 UTC
    
    Message: Identifier needed
    Line: 137
    Character: 48
    Code: 0
    URL: ../wp-content/plugins/user-role-editor/js/ure-js.js?ver=3.5.1
    
    Message: An object must given as value
    Line: 247
    Character: 1
    Code: 0
    URL: ../wp-admin/users.php?page=user-role-editor.php

    I’m not using IE8 willingly (work etc. 🙂 But anyhow, I’m guessing all these are related to the browser from the stone age since the actual editor isn’t working right. I’ve tried to re-install URE with no result.

    http://wordpress.org/extend/plugins/user-role-editor/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Can't update roles due to nonce check’ is closed to new replies.