Support » How-To and Troubleshooting » Can’t update permalink structure

Can’t update permalink structure

  • I used /index.php/%year%/%monthnum%/%day%/%postname%/ before I updated to 2.0. Having the brand new thing up and running I chanced on of the other permalink options. The result was a 403 on admin-panel and frontend. Only way to get back in is to upload a new empty .htaccess but the the permalinks are still set to the new option (%year%/%monthnum%/%day%/%postname%/). Any klick on a headline still leads to a 403.

    Any idea what the f*** is going on and how to stop that?

Viewing 15 replies - 1 through 15 (of 23 total)
  • i updated mine to 2.0 and it worked fine just like you had it…

    then all of sudden soemtime last night it didn’t…

    then, just as suddenly they started to work again…

    you might try deleting your .htaccess file….wait a lil bit, then update…i’ve heard that helps…

    good luck…

    If you needed the “index.php” in the previous version it was because your host/server doesn’t support mod_rewrite.
    If you are on the same host you’ll need the “index.php” even for the new version.

    Hi guys

    have a look at here….

    I’ve deleted .htaccess for roughly 16 times now – or rather, I uploaded an empty .htaccess since I can’t see that stupid file on my ftp-thing.

    Trouble is, the permalinks still work with index.php at the beginning only the links on the headlines do not feature that essential “index.php”.

    Sauerland I cannot acces your website so I think there is no .htaccess file present.

    Everytime I try to revert to the /index.php/%year%/%monthnum%/%day%/%postname%/ -scheme the entire site disappears. It only shows up again, if I upload a new empty .htaccess. But then the permalink-issue is still unresolved. And I can’t say whether there is a .htaccess even after I uploded it, since the ftp-thing doesn’t show it.

    I think I go and bang my head on the wall for a while and return to ink and paper.

    Sauerland, Ryan Boren send me this little plugin. It bypasses the pemalinkhandeling by wordpress and stores the permalinks directly into .htaccess.

    save it as rewrite.php and activate it as a plugin. It worked for me.
    Untill there is no solution you might want to used it.

    Thanks Mazalien, but that doesn’t solve anything.

    Every time I upload a new empty .htaccess, the front page reappears. But all permalinks are set to the option /%year%/%monthnum%/%day%/%postname%/ – and they always result in an error 403.

    When I change the permalinks to /index.php/%year%/%monthnum%/%day%/%postname%/ the entire site including the admin-panel disappears in a 403 and stays there until I upload a new empty .htaccess.

    And then everything starts from the beginning.

    The .htaccess-file disappears as soon as it is uploaded. What ever software I use – it stays hidden or deleted or whatever.

    The really frustrating thing is: Everything worked fine until I gave the other permalink option a try after updating to version 2.0.

    Sauerland, then you might want to have look at this reply from Ryan Boren :
    And I quote:
    “Plugins that used the mod_rewrite_rules filter need to use the generate_rewrite_rules action instead. generate_rewrite_rules has been the preferred method for some time, but Codex was still referencing mod_rewrite_rules.”
    Perhaps you shold deactivate your plugins one by one. Its a lot of work. I know…. :)-

    Or assist Ryan As he suggested over here about the same problem :

    I really appreciate your help, Mazalien. But now the entire thing is dead. Even the trick with the new .htaccess doesn’t work anymore. Perhaps my provider went berserk with the server.

    Would it help if I just reinstalled version 1.5.2?

    Well I did the same thing to test it out. Then the permalinks
    are working correctly. What I also did was that I set up a complete new blog in a seperate database with a fresh out of the box install of wp 2.0. with some dummy posts an pages. And even then the permalinks don’t work. If you wander around through this forum than you will notice that a lot of people have the same kind of problem. Ryan Boren said in a mail to me that he want to investigate the problem. So perhaps you should wait a while with your upgrade untill there is a solution. For me rewrite.php works. So I leave the install of 2.0 for a while as it is utill Ryan comes with a solution.

    Found it ! Deactivated the plugin “german-permalinks” and everything is fine again.

    So it is a plugin afterall that causes the trouble… those damned things.

    Autometa version 0.4b is from the empire of evil as well.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Can’t update permalink structure’ is closed to new replies.