WordPress.org

Forums

[resolved] Can't update pages with 3.9.1 (8 posts)

  1. Robbie S
    Member
    Posted 9 months ago #

    I have two WordPress sites on two different One.com servers. They work fine to surf to , BUT on either I can't update an existing page, or create a new one, after I upgraded to 3.9.1.

    I have tried:
    - Disabling all plugins.
    - Repairing the DB.
    - Using another theme.
    - Using different browsers (Safari, Chrome, IE, Firefox).
    - Downgrading to 3.9 and even 3.8.3.

    What happens is that after I changed the text and press the "Update"-button the little round spinning icon appears next to the button and after a little while the screen goes white. Then I have to either arrow back or type in the url for the admin to get back to WordPress.

    HOWEVER, once every 50 times it actually does update the page! And everything works like it is supposed to.

  2. You may need to turn on error reporting and watch your log files.

    It sounds like something is hooked to the "save post" part of WordPress. Themes and plugins can 'hook' to this function.. and perform additional tasks. If the theme/plugin does this.. and it's coded improperly.. it can create a loop. Eventually, the page will timeout and you will get a white screen.

    Your error logs would let you know if this is happening.

    Alternatively.. you can deactivate all plugins (Yes, ALL of them).. and go back and see if your post saves correctly every time.

    If it does.. then you know you have a plugin/theme not functioning properly.

  3. Robbie S
    Member
    Posted 9 months ago #

    Yes, as I wrote in my first post, I've tried to deactivate ALL plugins, switched to different themes, but the problem still remain with or without plugins activated or not.

  4. Robbie S
    Member
    Posted 9 months ago #

    I have also tried to make an error report, but it turns up blank.

    It seems like it's the server that is too impatient to wait for WP to finish up.

  5. Robbie S
    Member
    Posted 8 months ago #

    Update: I tried to change the password for a user on one of my WordPress-setups and I get the same result I get when I try to change a post/page ie. a ERR_EMPTY_RESPONSE (but most of the times the page is just white.)

  6. Robbie S
    Member
    Posted 8 months ago #

    Solution: After checking a lot of things I finally figured out that it was the settings on my ethernet-port on my computer that was causing the error.

    I'm using a Mac and when I changed the System Preferences > Network > Advanced... > Hardware > Configure to Automatic everything works fine again. So it wasn't even a WordPress problem to begin with.

    Sorry...

  7. SprialOwner
    Member
    Posted 2 months ago #

    Don't be sorry! I have the same exact problem and am going to try your solution now. Thank you!

  8. SprialOwner
    Member
    Posted 2 months ago #

    Didn't work for me. :-(

Reply

You must log in to post.

About this Topic