Support » Fixing WordPress » Can’t update any post or pages since 5.1

  • Resolved ini0r

    (@ini0r)


    Since the latest update I can’t update a single post or page on my blog.

    When I look at my server log I see many 404 :

    "POST /wp-json/wp/v2/pages/103?_locale=user HTTP/1.1" 404 469 "https://domain.tld/wp-admin/post.php?post=103&action=edit"

    And on the ui this message appears :

    “Updating failed”

    What a great update !

Viewing 10 replies - 1 through 10 (of 10 total)
  • Disabled all plug-ins -> no luck, event previewing a page does not work anymore !

    Hello ini0r,

    Go to the Settings->Permalink page and re-save your permalinks.

    See if this helps,

    Thanks.

    Hi kartiks16,

    thanks for your message.

    Unfortunately changing permalink doesn’t help, so since the 5.1 update I can’t update any post or page.

    Why there’s 404 on my logs when I try to edit a page ?

    Hello

    If you have any type of “security” plugin, make sure that you have not set it to disable the “REST API”. If the plugin has a setting for that, turn off the setting. If that doesn’t work, turn off the security plugin.

    if you’re blocking wp-json and thus blocking the REST API, then the new editor will not work.

    The new editor is a javascript application. It runs in your browser and communicates to your site using the wp-json REST API. You need to have that enabled. If you have added any security plugins, or anything similar to block that, then you will need to undo that in order for the editor to work properly.

    • This reply was modified 6 months, 3 weeks ago by  Kartik Shukla.

    Hi,

    thanks for your reply.

    I did not install any form of security plugin, even disabling all of the installed plugin doesn’t solve the issue.

    I did not changed anything regarding this REST API so I don’t understand why it is suddenly not working.

    At my knowledge the latest change was the 5.1 update, before I could update or change pages & posts..

    This new editor is added by 5.1 update ?

    SOLVED : Found that my .htaccess file was not owned by webserver user, fixing this allowed me to udate & change post/pages again.

    Thanks for your help !

    • This reply was modified 6 months, 3 weeks ago by  ini0r.

    I had the same problem. I can’t even start to write a new post. It always gives error. Had to install the plug in for classic wordpress editor.
    wordpress 5.1 is really bad!!!!

    I have the same problem. No plugins installed. The posts and pages won’t get saved. Really weird.

    Hello,

    I had the same problem and solve it installing the classic wordpress editor extension.

    WordPress 5.1 is not as good as ! Disappointed…

    My websites have been updated to 5.1.1 which has a Block Editor (Gutenberg). The Block Editor really messes up my html and websites layouts when I try to update so I installed the Classic Editor Plugin. The problem is when I try to update a webpage with the Classic Editor is it just redirects to the homepage of the website and doesn’t save the update. The only way I can update is by using the Block Editor which, as I stated, messes up the layout by adding or removing important elements.

    What’s even weirder is if I copy and paste a template code that I use for posting weekly articles into a brand new post using Classic Editor it does the same thing.

    So not only can I not make updates to an existing page or post using the Classic Editor I also cannot paste html into the Classic Editor and create a new page or post. If I add a new page or post and simply type something using the Classic Editor it will save but I can’t add html. Very strange.

    A work around I’ve found out is to save in Block Edit then switch to Classic Edit to make any update. Then literally copy the code in Classic Edit mode, switch back to Block Edit mode, paste the code (that was edited in Classic Edit mode), and finally update it. If I try it any other way Block Edit makes a mess of the layout. And if I try to save in Classic Edit mode it will not save and just redirects to the homepage.

    I’ve been dealing with my server’s support (LeaseWeb) and they’ve basically come to the conclusion that it is my problem advising me to contact WordPress support. I’ve attempting to deactivate each of my plugins one by one testing each time and the problem still exists. And this issue exists on all my websites that have the WordPress update.

    All I want is to return to using the Classic Editor so I can update my websites and create new pages using my existing html templates. Any ideas of how to go about fixing this issue? Rolling back to a previous version of WordPress that doesn’t have Block Editor?

    Here’s a video that might help to better explain when setting up a new post… http://getsmarthomedevices.com/New-Post-Classic-Editor.mov

    Here’s a video showing if I try to update an existing page in the Classic Editor… http://getsmarthomedevices.com/Updating-Post-Classic-Editor.mov

    Result is the same, redirect to homepage and no saved post. Really, really, really frustrating 🙁

    Same issue with me and i installed classic editor and it’s work fine.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.