Support » Fixing WordPress » Can’t update all selected plugin once

  • Hi,
    I have installed WP (5.1) on my NAS Synology with the multi-site option.
    For some reasons I can explained, when I try to update all the plugins selected, the update works only for the first one on the list.
    I just can select one plugin at a time and update it one by one.
    This is not really convenient nor fast. It takes me an hour to update the dozen plugins of my environment πŸ™
    Any help or any idea why this is happening will be really appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi @ucan74 , Most likely there’s a plugin conflict, what i mean is, one or some of your plugins are preventing that functionality.

    There are many factors why the update fails. It could be that there are plugins or the theme that causes conflicts, your server is full of requests or you have a low value for the execution of php code usually 30 or 60 seconds informed with your host if you can increase this limit without breaking their policies. Obviously the hosting must have a fast connection.
    https://www.php.net/manual/en/info.configuration.php#ini.max-execution-time
    PHP_INI_ALL Entry can be set in php.ini, .htaccess, httpd.conf ini_set(), Windows registry or (.user.ini since PHP 5.3)

    Thread Starter ucan74

    (@ucan74)

    Thanks for your replies guys.

    Well in fact updating the plugin is Ok, it does work.
    But if I check all the plugins and that I try to update them in one time only, that doesn’t work. I have to update the plugins one by one, one after the other one.

    I’m hosting the site on my own NAS Synology and I have a very fast connection (fiber).

    I’m not sure I understood what exact value or variable I should check autotutorial?

    • This reply was modified 2 years, 6 months ago by ucan74.
    Thread Starter ucan74

    (@ucan74)

    My max_execution_time = 600

    Is it too big, too low?
    I have no idea πŸ™

    Hi, you have to write on the synology forum for how to increase php max_execution_time, indicating which php version is in use and which synology version you use. Sorry this configuration is strictly synology so they can help you.

    https://www.php.net/manual/en/info.configuration.php#ini.max-execution-time
    PHP_INI_ALL Entry can be set in php.ini, .htaccess, httpd.conf ini_set(), Windows registry or (.user.ini since PHP 5.3)

    Note* the usefulness of max_exexution_time is in the fact of not letting die a php script badly written, I will change you manually only when you have to make several updates and then set it to 30 or 60 seconds.

    Thread Starter ucan74

    (@ucan74)

    Thx for your help autotutorial.

    I know how to change this value (no need to ask Synology forum).
    As I said the max_execution_time is set to 600 on my system.

    As far as I understand it seems to be 600 secondes.
    And from what you said it sounds way too much and I should modify it to 30 or 60 sec.

    I will give it a try when I’ll have new versions to update.
    It’s all updated for now.

    • This reply was modified 2 years, 6 months ago by ucan74.
    • This reply was modified 2 years, 6 months ago by ucan74.
    • This reply was modified 2 years, 6 months ago by ucan74.
    • This reply was modified 2 years, 6 months ago by ucan74.

    Yes πŸ™‚
    then it depends if you have to work with a huge amount of data you have to choose the seconds that are most suitable for you .. sometimes some plugins indicate to set to 180 seconds.

    Thread Starter ucan74

    (@ucan74)

    Ok I see.
    I’ve changed to 60 sec. I have to wait until new plugin updates…

    When you need to upgrade the 12 plugins try setting at 40 minutes (2400 seconds)
    see you later.

    Thread Starter ucan74

    (@ucan74)

    Ok, I’ll do that… Thanks πŸ™‚

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t update all selected plugin once’ is closed to new replies.