Support » Localhost Installs » Can't update Akisnet plugin: Unable to Create Directory

  • This is my first Ubuntu/LAMP/WordPress install. I’ve installed Ubuntu Desktop, LAMPS, vsFTP and WordPress. I’m able to add pages and view them in WordPress. The installation directions I followed instructed me to copy the WordPress files to /var/www/ so that’s where WordPress is running from.

    However, after the default install, the Aksinet plugin is listed as needing an update. When I attempted to update the plugin, I received errors relating to the FTP settings, which I resolved by creating a new user in vsftp and configuring that user so that his home directory is /var/www/.

    That resolved my ftp errors, but now I get “Unable to Create Directory” as the error message when I attempt to update the plugin. Following a tip on from another post, I tried chmod 777 wp-content but that didn’t resolve the issue.

    Appreciate any suggestions.

Viewing 1 replies (of 1 total)
  • Hi Steve5877,
    I just ran into the exact same problem. I’ve got this Social Space plugin of mine. I just released v2.0 of that so wanted to check how the upgrade feature works. When I hit upgrade, it downloded the latest version but could not create directory for it.

    I tried a few things and got this solution. I first Deactivated the previous version and then hit the upgrade. And it said Update successful.

    I’m not sure whether this is the correct solution, but it did work for me.

    Hope this helps.

Viewing 1 replies (of 1 total)
  • The topic ‘Can't update Akisnet plugin: Unable to Create Directory’ is closed to new replies.