Support » Fixing WordPress » Can't unpack/install plugins

  • I can’t seem to get any plugins to install anymore. I’ve tried clicking add new plugin, search and then click install now, I’ve tried clicking details and then install, and I’ve tried uploading the files. It either gets stuck at unpacking the plugin or gives me the message “Fatal error: Maximum execution time of 10 seconds exceeded in /home/a5991106/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 172”. It still installs it when I get the error, but won’t activate it because it states there is a fatal error.

    I tried deactivating plugins I had activated and deleted others I’d installed and found I didn’t need but it hasn’t helped.

    How can I stop the error and get plugins to start installing properly again?

Viewing 8 replies - 1 through 8 (of 8 total)
  • It looks like your host doesn’t allow any script to run for more than 10 seconds and probably plugins take longer to install. Hence to errors.

    If it doesn’t work try the old-fashioned way by downloading the plugin to your computer, unpack and then upload it using a FTP-client.

    I kept getting the error before but when I tried again things usually installed.

    I already downloaded it to my computer. I have now unpacked it then uploaded it.

    I got an error on one file: Warning: ftp_put() [function.ftp-put]: Could not open data connection to port 54069: Cannot assign requested address in /home/mainhost/public_html/file-manager/includes/ on line 2566

    The plugin is not listed under plugins…

    The files still uploaded despite the error, but I reuploaded the files that caused that error and they uploaded fine. The plugin still isn’t listed though, is there something else I need to do?

    Is there any way to allow the script to run for longer?

    Try to upload it using an FTP-client instead of the WordPress functions.

    You can alter the script execution time if you know this in PHP and the server admin allows it, which I doubt.

    I have an FTP client but it keeps saying it can not connect. Where does it upload the files too though? The host site?

    Moderator Andrew Nevins


    Forum moderator

    Ask your hosting company for your FTP details. It sounds as though you’re using the wrong details.

    Possibly, but I was looking at details that said FTP and a tutorial for the program. But either way, does it upload to the host site? If it does then I already have all the files on there…if not, where is it uploading to?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can't unpack/install plugins’ is closed to new replies.