• Can’t deactivate from network. Nothing happens. How can I remove the mashsharer plugin from my multisite website?

    Regards
    Øystein

Viewing 13 replies - 1 through 13 (of 13 total)
  • Please try if you can not deactivate other plugins as well.

    Usually this is a problem by your WordPress and not MashShare.

    Make sure there is no server side caching running.

    Thread Starter Øystein Thune

    (@thune)

    Don’t think so. No WordPress problem at all. This is the only plugin that won’t uninstall. Server is running php 7.1 and everything is working fine.

    Lot’s of servers run server side caching, so then you should warn people before they install, that if you run server side caching you won’t ever be able to uninstall.

    Thread Starter Øystein Thune

    (@thune)

    I have tried every browser and the deactivate link for network is just inactive. Nothing happens when I click on it. I think you should provide me with some kind of information to have to fix this. Can I delete it manually? How is that done on a multisite?

    Hi,

    it depends on how you activated the plugin, globally or on a per site base.

    If you have issues the easiest thing would be to uninstall it manually. Just remove the plugin folder “mashsharer” from the site you want to uninstall it. You find it in wp-content/plugins/mashsharer

    If you still have issues feel free to open a support ticket here: https://mashshare.net/contact-developer/

    Thread Starter Øystein Thune

    (@thune)

    Tried your support ticket system, but I couldn’t provide all the information you require because this is the free version. I’m not paying for a product that I want to uninstall. It’s preventing me completing av project.

    Thread Starter Øystein Thune

    (@thune)

    BTW: I don’t understand why this ticket is marked resolved. This is a huge problem for me and you just mark it resolved?

    You are free to open a support ticket there without providing any license key. I can help you better and faster by mail instead using this forum.

    Beside of that:
    Deleting the MashShare plugin folder by FTP is working anytime, no matter if there are any issues by using the WordPress deactivate function.
    That’s why i resolved the topic here.

    Have you already tried this?

    There are more than 70.000 active MashShare users and we never had any similar support question so i can only assume that either something special in your multisite setup

    One possible issue could be that you installed MashShare directly on one of your sub sites and NOT by using the network installation capability of WordPress multisite.

    If thats that case it’s likely that the network deactivation is not working so you need to deactivate and remove the plugin directly from the sub site.

    Again: This will work so there is no need to keep this ticket open but i will be informed if you reply here and will answer back to you of course.

    Regards
    René

    • This reply was modified 6 years, 9 months ago by Rene Hermenau.
    Thread Starter Øystein Thune

    (@thune)

    Just one question to this. Would it leave mashshare stuff in the database if I just delete it with FTP?

    Yes, but you can delete these data as well by finding the tables with phpmyadmin and delete them manually:

    /** Delete all the Plugin Options */
    delete_option( ‘mashsb_settings’ );
    delete_option( ‘mashsb_networks’);
    delete_option( ‘mashsb_installDate’);
    delete_option( ‘mashsb_RatingDiv’);
    delete_option( ‘mashsb_version’);
    delete_option( ‘mashsb_version_upgraded_from’);
    delete_option( ‘mashsb_update_notice’);
    delete_option( ‘mashsb_tracking_notice’);
    delete_option( ‘widget_mashsb_mostshared_posts_widget’);
    delete_option( ‘mashsb_tracking_last_send’);
    delete_option( ‘mashsb_update_notice_101’);
    delete_option( ‘mashsb_valid_fb_api_key’);

    /* Delete all post meta options */
    delete_post_meta_by_key( ‘mashsb_timestamp’ );
    delete_post_meta_by_key( ‘mashsb_shares’ );
    delete_post_meta_by_key( ‘mashsb_jsonshares’ );

    //delete transients
    delete_transient(‘mashsb_rate_limit’);
    delete_transient(‘mashsb_limit_req’);

    Before you delete it manually try first to deactivate and uninstall MashShare directly from the sub site wp-admin instead using the network deactivation function.
    I think this should be working.

    Thread Starter Øystein Thune

    (@thune)

    It’s not installed on a subsite and there is nothing wrong with the multisite because I have installed and uninstalled lots of plugins. It’s just this one that is a problem. The deletes looks messy and I afraid of breaking something on a live site. But since you are 100% sure that there is nothing wrong with the plugin I guess I have no choice…I think I just have to rate this a one star and explain why … Thanks anyway

    My offer is still valid. If you like more ongoing and dedicated support from me you can open a support ticket: https://mashshare.net/contact-developer/

    Thread Starter Øystein Thune

    (@thune)

    Thanks, I have sent a message now. This time it work. I had written something in the license field and that did not work.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Can’t uninstall (deactivate from network and delete) from a multisite’ is closed to new replies.