Support » Requests and Feedback » Can’t turn off moderation of comments

Can’t turn off moderation of comments

  • Even though I have unchecked An administrator must approve the comment (regardless of any matches below), all comments seem to go into the moderation queue–including my own as admin.
    I’ve tried toggling the setting on and off to no avail.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Try putting a single word into the spam moderation box, and see if that helps ?
    Could you post back the result please ?

    This particular blog is for my high school students in spanish, and I had already put a list of 12 obscenities in the list before my initial question. Shall I try removing my list instead?

    Make sure there is not a blank line in there, usually at the bottom. That could cause this too.

    That appears to have been the problem. Deleting the last line fixed it. Thanks!

    Hi folks, I’m having the same problem as dherren, and I too had a blank last line at the bottom. However, having deleted it, I still cannot get comment moderation to turn off.
    I’m running WP 1.2.1. This has been going on for some time, both before and since I installed Blacklist (2.6.1). I have tried it with even the box unchecked for requiring a name and email. No joy.
    I’ve searched the forums and the web and seen a couple others with the same problem, but so far I haven’t found a solution.
    Any help would be greatly appreciated.

    Seems like I am not the only one. =(

    same problem here

    I guess I’ll have to assume this is a known WP bug. If any work-around exists that any of you know of, please post it in a reply. I’d be extremely grateful.
    IMO it’s a pretty serious issue because moderating comments drives away would-be participants in a blog.
    Thanks for any help and ideas.

    Are you absolutely certain you have checked your spam words list ?

    Yes, I’ve checked it numerous times. The first time there *was* a blank line at the end. I removed it, but comment moderation remained on. I have since removed all words but one on the list and made sure there are no blanks. Comment moderation still is stuck.
    I’ve seen posts from a few others in the same boat, which leads me to conclude there’s a bug at play.

    I am having the same issue. I also found a blank space in the keyword area, yet having deleted it caused no visible effect. I’m still getting tons of notifications.

    The irony is, that as of yesterday I’ve implemented a new plug-in that stops comment spam completely. It requires users to match icons before submitting a comment. While no spam gets through, I’m still being notified. Furthermore, nothing ever ends up in the queue because nothing gets past the spam block. [sigh]

    The bottom line is, I just want that when I leave the box for notifications unchecked that I don’t get notifications. Essentially, I’ve stopped spammers but I’m being spammed by my own blog. Ugh!

    Same issue here. Using WordPress 1.2.2 on OSX (server version, 10.3.7), PHP 4.3.2.
    I liked the ease of installation very very much.
    I wish there were more systematic documentation.
    Have checked “allow to post” and unchecked comment moderation, but postings still do not appear on the blog, and only by logging in as Admin and going to the Edit tab do I see the postings waiting for approval.
    My spam word list has no blank lines.

    Moderator James Huff


    Does your blacklist have any / characters of single letters?

    same problem with my site: “usual settings” and “email me whenever” options unchecked with some “poker” related comment moderation words, with no blank lines or single characters, and an inbox where I receive spam from myself!

    deleted my email address from the “General Options” page. crude tactic, but it seems to be working.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Can’t turn off moderation of comments’ is closed to new replies.