WordPress.org

Forums

Hupso Share Buttons for Twitter, Facebook & Google+
[resolved] Can't turn buttons back off? (3 posts)

  1. mw360
    Member
    Posted 2 years ago #

    To this point, have been using this for ONLY the shortcode feature - allowing me to place the buttons in the header via a hook. Has worked great to this point.

    Right after the last update, I thought I would try seeing how things might look like if I allowed buttons to show on each post - so I checked some of the boxes. That was a mistake, because since doing that, now I can't turn them back off.

    I have unchecked all boxes, and even highlighted ALL of the categories in the category exclusion section - none of it matters. Have cleared (and even removed) caching, have cleared browser cache, and completely removed and re-installed Hupso itself - no matter.

    I should note that the other settings in Hupso do work though - so I can still choose whether to show buttons above, below or both, and those changes do appear. Unfortunately, the options to not show them at all just doesn't work. :-(

    So, I restored my backup (with previous plugin version/settings), and it comes up as it did before I made the changes (just the shortcode showing in the header) - but as soon as I add checks to show in posts/pages, once again, they show everywhere - and unchecking doesn't turn them back off.

    While I could continue to use it from my restore config, I am inclined to not do so until I can figure out why this is happening.

    Is there anything I could look at that might shed light on this?? I would really like to continue using this but not if a settings change can't be reversed.

    Thanks for any thoughts

    http://wordpress.org/extend/plugins/hupso-share-buttons-for-twitter-facebook-google/

  2. kasal
    Member
    Plugin Author

    Posted 2 years ago #

    You are right. I have just tested this and there really is a bug. If you use shortcodes before the post the buttons will show under posts every time.

    I will fix this in the next release. In the meantime you can edit your hupso shortcodes to look like this:

    <?php
    echo do_shortcode('[hupso]');
    global $HUPSO_SHOW;
    $HUPSO_SHOW = false;
    ?>

    This will prevent the buttons from showing up under post.

  3. kasal
    Member
    Plugin Author

    Posted 2 years ago #

    This is now fixed in the latest version of the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Hupso Share Buttons for Twitter, Facebook & Google+
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.