Support » Plugin: Wordfence Security - Firewall & Malware Scan » Cant Translate ERROR: The username or password you entered is incorrect.

  • Leandro

    (@leandrorocha)


    Hello,

    Since I enabled the option “Don’t let WordPress reveal valid users in login errors” the phrase in login page when someone enter with a wrong password or user changed to “ERROR: The username or password you entered is incorrect. Lost your password?”

    However I cant find where is this phrase is available in wordfence translation files to allow me to translate to my language. I already tried several differents combinations of keywords and still cant find it.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hello,
    I’m afraid to say there is no possible way to do that at the moment, we are taking steps to make Wordfence translation ready but this isn’t in a complete stage yet, this issue has the internal reference number (FB761).

    Thanks.

    It can be fixed manualy in wordfenceClass.php file

    Is this really resolved? Because I still experience this issue. And no, I don’t see changing plugin’s code to be a solution :/

    Thanks.

    Hi,

    We noticed that the string itself is wrapped with the translate function but it’s missing the textdomain. Could you please add the ‘wordfence’ textdomain to the corresponding string in lib/wordfenceClass.php?

    ranone

    (@ranone)

    I still have this problem with the latest version 7.1.16.

    When do you plan to solve this issue?

    domridout

    (@domridout)

    Same problem here, would be great to have a fix for this. Is there really no temporary solution?

    Thanks

    I have the same problem too. Is this going to be resolved in the next actulization?

    Why is this ticket labeled as resolved?

    I think it’s never going to be resolved, since they have already marked it as “resolved” :/

    Plugin Support wfdave

    (@wfdave)

    Hi @zviera, @tamarazambrana, @domridout, @ranone, @level-level, and @leandrorocha,

    I’ve unresolved this thread (I don’t know why it was marked resolved in the first place).

    So I’d like to update all of you at once, and I’m sorry we didn’t respond to this thread sooner.

    1. It seems this feature was put on delay a while, but they are still working on getting wordfence completely translation ready!

    2. That being said, I’ve gone ahead and sent a feature request to the team so that it may be possible to modify this string through the Wordfence options. ( Possible design: https://i.imgur.com/kziOWaT.png )

    3. For now, there is a temporary fix that I can supply for all of you!

    Temporary fix

    a. Edit the file /wp-content/plugins/wordfence/lib/wordfenceClass.php
    b. Go to line 2382 and 2793
    c. Change the two lines to your desired strings

    The two lines will have the entire string:

    '<strong>ERROR</strong>: The username or password you entered is incorrect. <a href="%2$s" title="Password Lost and Found">Lost your password</a>?'

    I’ll try to keep all of you updated on this thread when I get more information.

    Thanks!

    Dave

    Come on guys, 2019 and this still has not been solved? We are living in an international world now, can you please internationalise this after all?

    You know that messing with files is not a proper solution, and not that temporary any more as it it almost a year now.

    Please, make this update happen!

    You can’t be serious. Still not resolved? This is a 5-minute fix even for a mediocre developer. This is ridiculous.

    Just ran into this with my one-country webshop and figured out a way to do it from a child theme, no need to edit a plugin’s files. =] Chances are pretty good people are using a child theme nowadays anyways, so:

    1) Create a directory for storing the .po/.mo files inside your child theme. I picked wp-content/themes/mychild/l10n/wordfence

    2) Create a .po file with contents like:

    msgid "<strong>ERROR</strong>: The username or password you entered is incorrect. <a href=\"%2$s\" title=\"Password Lost and Found\">Lost your password</a>?"
    msgstr "<strong>FOUT</strong>: De ingevulde gebruikersnaam of het wachtwoord is onjuist. <a href=\"%2$s\" title=\"Wachtwoord vergeten\">Wachtwoord vergeten</a>?"

    3) Convert it to .mo. Without any plugins and on a *NIX system you can just do (make sure gettext is installed first): msgfmt nl_NL.po -o nl_NL.mo

    4) In your child theme’s functions.php, add this:

    function my_wf_l10n() {
    	load_textdomain('default', get_stylesheet_directory() . '/l10n/wordfence/nl_NL.mo');
    }
    add_action('after_setup_theme', 'my_wf_l10n');

    This will load the specified .mo file into the “default” text domain and voilá, translations now take effect. I’m pretty sure there are a ton of other strings you can translate this way as well, until WF finally decide to fix it themselves (if they ever do). Luckily the lockout page seems to be translatable using the good ol’ wp-content/languages/plugins/wordfence-nl_NL.mo

    • This reply was modified 7 months, 3 weeks ago by sahbi.
    • This reply was modified 7 months, 3 weeks ago by sahbi.
    duodigital

    (@duodigital)

    No news on this case?

    I what @wfdave suggested above and it made no difference, the messages were still being sent in English.

    Any update on this?

    SERIOUSLY?!

    You just can’t implement a 5 minute hot-fix over couple of years?

    The workaround is useless, because it gets rewritten with almost every update – which is pretty much daily.

    Come on. Really.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.