Support » Plugin: WP Recipe Maker » Can’t translate all nutrition values like ‘carbohydrates’, ‘fiber’ etc.

  • Resolved rockyourblog

    (@rockyourblog)


    Hey there,

    how can we translate the nutrition values like “calories”, “fat”, “iron”, “calcium” etc. shown in the recipe?

    I tried to translate these strings in the template editor (i have one template for DE and one for EN recipes) but couldn’t find them under “recipe nutrition” or “nutrition container” blocks.

    I tried to translate them with Polylang string translation, which worked with other elements of WP Recipe Maker before, but the nutrition strings don’t show there either.

    I tried the *.pot file of WP Recipe Maker but the required strings are not listed there.

    I tried the *.pot file of WP Recipe Maker Premium – but there is not even a *.pot file.

    Okay, then I thought maybe just create a new translation from one of the existing *.po files, I tried “wp-recipe-maker-premium-fr_FR.po”.

    But I quickly noticed that there are missing strings in these files, too. I could translate strings like “iron”, “potassium”, “trans fat” etc. but failed to find the strings for “carbohydrates”, “fat”, “servings” and “fiber” for example.

    Regarding “carbohydrates” for example, there is a string in these *.po files called “Total Cabohydrates”, but that seems not the one displayed in the recipe, where the nutrition facts are listed. Apart from that there is no other string referencing “carbohydrates” in any way. “Fiber” hast the same problem with “Dietary Fiber” and so on.

    So my nutrition values are now translated only halfway.

    Your plugin is really great and I’m using the premium version on a couple of websites, but translating the recipes is and was really a pain since the beginning, especially while using a multi language setup.

    Maybe I’m just blind as a bat and it’s really simple to do, but at the moment, I’m at my wits’ end.

    Any help would be apprecciated.

    Greetings
    Philipp

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Brecht

    (@brechtvds)

    Hi Philipp,

    The nutrients label is set on the WP Recipe Maker > Manage > Your Custom Fields > Nutrients page.

    This label is also put through the i18n function so it should be availble under string translation as well, although I’m not that familiar with Polylang.

    rockyourblog

    (@rockyourblog)

    Hey Brecht,

    thanks for the fast reply.

    Ok, but if I’m going to translate the nutrition labels under “Custom Nutrients” page you mentioned, they will be displayed in that language regardless of the site language. So I get german labels in an english recipe for example.

    Maybe I could duplicate every nutrient and create a german version of it. When creating a recipe I would then only use the nutrients with the correct language and leave the other empty so that they don’t get shown. But thats not really a statisfying solution to be honest.

    I don’t know why the strings aren’t showing in Polylang string translation either.

    Hm.

    Plugin Author Brecht

    (@brechtvds)

    You definitely should not do that as the default nutrients are used in the metadata, so you don’t want to duplicate things.

    Polylang should pick up on this. I’ll be able to do some testing tomorrow.

    Plugin Author Brecht

    (@brechtvds)

    Hi again,

    I was able to successfully translate those nutrients by just leaving them at their default values on that Manage page I mentioned.

    I just used the Loco Tranlate plugin to translate the “wp-recipe-maker-premium” domain. I did have to use the “Create Template” option in Loco Translate and sync it (which basically creates an up-to-date .pot file).

    After doing that, all nutrients were available for translation and showed up in the correct language in Polylang.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t translate all nutrition values like ‘carbohydrates’, ‘fiber’ etc.’ is closed to new replies.