Support » Plugin: WP Recipe Maker » Can’t switch recipe to published

  • Resolved NBH707

    (@nbh707)


    We also have the premium plugin so I am not sure what the source of this issue is. However, when I change the setting of status of a recipe from nothing to “Published” and then save it, the “published” status does not get saved. The only way I can set a recipe to published is to go into the database and manually change it.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Brecht

    (@brechtvds)

    You have recipes set as a public post type on the WP Recipe Maker > Settings > Post Type & Taxonomies page?

    Could you clarify what you mean by status of “nothing”? The status should never be nothing. As soon as you save a recipe it should be “Draft”. Is that not the case for you?

    Thread Starter NBH707

    (@nbh707)

    They show as “scheduled” on the manage page. But when I open them up to edit there is nothing shown under status. Then I select “publish” and save, but nothing changes. It is still blank when I open it again (and it still shows as scheduled on the manage page).

    Yes, I have recipes set as public post type.

    The post in which they are embedded is set to “scheduled.” But I will be converting these to recipe roundups and I recall you told me that with roundups, recipes would not be published automatically when the scheduled post got published, so I want to change them to “published” before I add the roundup version.

    Plugin Author Brecht

    (@brechtvds)

    Oh, you’re embedding them into a parent post? In that case, a recipe takes over the status of the parent post. When that post gets published, the recipe becomes published as well.

    But it sounds like this is supposed to be a roundup post? In that case, you want to add a “Recipe Roundup” block/shortcode and not a “Recipe” block/shortcode.

    By adding it as a recipe you’ve made that post the parent post, linking their status.

    Thread Starter NBH707

    (@nbh707)

    All that you say is correct but it’s an issue of our editorial process. The authors are embedding the recipes in the posts as they write them and they are reviewed and edited in that format, and then only before final approval am I converting them to roundup blocks.

    But it sounds like this is expected behavior and I just need to convert them all to published after I finish adding the roundup blocks at the end. I’ll see if that works.

    Thread Starter NBH707

    (@nbh707)

    Nope, that didn’t work.

    Here’s what I did:
    1. I converted all the recipes in the article to roundup items.
    2. I published the article.
    3. In the manage recipes page, the recipes were still showing as scheduled.
    4. I tried using bulk edit to publish them all, but after doing so, they still show as scheduled and aren’t accessible.

    Plugin Author Brecht

    (@brechtvds)

    Is it not an option to have the authors create the recipes on the WP Recipe Maker > Manage page instead? That won’t mess up the parent post link.

    What is the parent post for those recipes when you check the WP Recipe Maker > Manage page?

    Thread Starter NBH707

    (@nbh707)

    No we actually are only having articles with recipes even be composed on our site (everything else is done elsewhere) as we want to limit access and we have set it so that authors can’t access the manage page and can only add recipes via the post editor.

    The parent post is still showing the post they were originally added to.

    Plugin Author Brecht

    (@brechtvds)

    And what’s the status of that post?

    Thread Starter NBH707

    (@nbh707)

    I published it briefly for testing purposes but I have set it back to scheduled again.

    Plugin Author Brecht

    (@brechtvds)

    Could you test temporarily publishing and see if you can change the status by editing the recipe then?

    Thread Starter NBH707

    (@nbh707)

    That doesn’t fix the problem either, whether I use the bulk edit or edit just one recipe.

    Thread Starter NBH707

    (@nbh707)

    I tried that. It didn’t make a difference. I disabled all other plugins and the theme even to just make sure we aren’t dealing with some sort of conflict here.

    I think there must be something in the code that only allows a recipe to be published when its parent post gets published, if the parent post has the recipes directly included in the post. If the recipes are just roundups, it won’t publish them when the post gets published and there is no way to set it to published independently.

    This makes sense in a way as the way I am doing it, the recipes are a separate post type and therefore their publication status is independent of the parent post publication. When the recipes are embedded, their publication status is simply a formality because they are part of the parent post.

    Plugin Author Brecht

    (@brechtvds)

    Could you send an email to support@bootstrapped.ventures for a second?

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.