WordPress.org

Support

Support » Plugins and Hacks » can't start backup, WPDB Error

can't start backup, WPDB Error

  • I’ve backup using this plugin on this site previously.

    Now I’m getting: “You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘ NULL, , 0, 0, 0, 0, 0, 0, 0, 0, 0, 0)’ at line 1. Last query: INSERT INTO wrd_wponlinebackup_activity_log (start, end, type, comp, media, compressed, encrypted, errors, warnings, bsize, bcount, rsize, rcount) VALUES (, NULL, , 0, 0, 0, 0, 0, 0, 0, 0, 0, 0)”

    Any help would be appreciateed

    http://wordpress.org/extend/plugins/wponlinebackup/

Viewing 15 replies - 1 through 15 (of 40 total)
  • I’m getting this too! It’s worked fine for me in the past, but no longer will run a backup. I’m on a WP Network–not sure if that’s related.

    Thanks!

    yep – I’m network too – i’ve backup with it previously without issue.

    from the SQL syntax it looks like it can’t calculate the start value which can’t be NULL, this is probably the start time of when you kick it off.

    Scott

    nothing – nice – time to look for another backup tool

    Plugin Author Online Backup
    Member

    @driskell

    Hi eef-ink,

    Is there a specific version of our plugin that used to work? Or is it just used to work and now stopped?

    We haven’t yet made the plugin fully compatible with Network yet. We’ve been working on some fixes in the past and some worked and some didn’t, as it turned out Network was more complex than we thought.

    We’re working in the background gradually on fixing the problem. If there a specific version that used to work we can likely see what changed and fix it much quicker. But at the moment it’s some substantial changes we need.

    Snewby – Likewise, if you remember which version worked or what changed when issue started, it will help.

    Regards,

    Jason

    Plugin Author Online Backup
    Member

    @driskell

    Hi guys,

    We’re halfway there now. We’ve finished half of the changes required so it should now backup. This is beta so best to not run in production unless you are absolutely sure. I’ve done some thorough testing though.

    It will move the Online Backup page from Tools -> Online Backup into the Network Admin under it’s own entry. So to run a backup is only possible from Network Admin. If you Network Activate it doesn’t appear on individual sites. If a site admin activates it because you didn’t network activate, it simply does nothing, but says “Managed by Network Administrator” next to it in the plugin list.

    You can download it here:
    https://wordpress.backup-technology.com/wponlinebackup-533-multisite.zip

    If you are able to test it, let me know how it goes. Or any suggestions on behaviour changes etc let me know.

    I’m aware of only two things at the moment:
    * Schedules are untested – I’m doing that later today
    * On General Settings the excludes will allow you to exclude the multisite builtin tables for WordPress, and individual builtin tables for other sites. This is minor and might be postponed for a future update so we can push this multisite compatibility out ASAP.

    Any feedback is welcome.

    Thanks,

    Jason

    I deleted the previous version and installed the version you linked to in the above post, but I still get this error:

    The backup failed to start: WPDB error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘ NULL, , 0, 0, 0, 0, 0, 0, 0, 0, 0, 0)’ at line 1. Last query: INSERT INTO wp_wponlinebackup_activity_log (start, end, type, comp, media, compressed, encrypted, errors, warnings, bsize, bcount, rsize, rcount) VALUES (, NULL, , 0, 0, 0, 0, 0, 0, 0, 0, 0, 0)

    I honestly don’t remember which previous version worked–but I did back up my network 11/19/12 if that helps–I do always update my plugins as soon as I see there are updates available.

    Plugin Author Online Backup
    Member

    @driskell

    Hi eef-ink,

    This is quite odd. If you go to Activity Log what happens then?

    Also, can you confirm where the Online Backup page is? Is it in Network Admin or is it in the Admin for one of your sites?

    I’ll see if I can add a bit more information to the Help & Support information for multi sites that might help us.

    Regards,

    Jason

    freedompreneur
    Member

    @freedompreneur

    Hi Jason,

    I am having the same WPDB error as eef-ink. I am running WPMU 3.5.1 and I installed your beta 533-multisite and same error occurs.

    To answer your previous questions:

    Yes the Online Backup Page is now on the Network Admin.
    Online Backup Page is not showing up in the child site admins as planned.
    Activity Log seems to be reporting the error.

    Regards,
    Michael

    Plugin Author Online Backup
    Member

    @driskell

    Hi freedompreneur,

    Can you post the information from Help & Support?

    Also, can you tell me, when you access Network Admin, are you logged into the main site or a different site? Are you using subdomains or subfolders for the Network?

    Thanks,

    Jason

    Hi!
    So, when I login to the Network Admin I see the Online Backup in the WP sidebar. I don’t see it when I go to any of my sites’ dashboards.

    I’m logged in as Super Admin for the network–all-access to all sites.

    So the Online backup ONLY shows on the actual Network Admin, not any of the sites, including the main site on the network.

    The activity log looks like this:
    http://eef-dev.com/temp/onlinebackup.JPG

    The events listed are:
    http://eef-dev.com/temp/onlinebackup2.JPG

    Hope this helps! Thanks!

    Plugin Author Online Backup
    Member

    @driskell

    Thanks eef-ink,

    Could you provide the multisite settings from your wp-config.php? I wonder if they’ve been changed. No matter how much I try here I can’t seem to reproduce this problem. I wonder if there has been some change to the multisite config so it isn’t “normal”, such as changes to the SITE_ID_CURRENT_SITE

    Jason.

    Hi Jason,

    I’m not sure exactly what you need… I have the file, but what specifically do you need from it? Thanks!

    Plugin Author Online Backup
    Member

    @driskell

    Hi eef-ink,

    If you look through notepad there should be some area with:
    define(‘MULTISITE_ENABLED’

    Or something similiar. If you can copy that block including the SITE_ID_CURRENT_SITE and BLOG_ID_CURRENT_SITE, it will help.

    I’m also putting in a bit more information in next version to help diagnose if we need it.

    Jason

    This is what mine has:

    define(‘WP_ALLOW_MULTISITE’, true);
    define( ‘MULTISITE’, true );
    define( ‘SUNRISE’, ‘on’ );
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘eef-dev.com’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    Plugin Author Online Backup
    Member

    @driskell

    Oh so the SUNRISE is on. Are you using the Domain Mapping plugin by any chance?

    Is the Network Admin page you are using to run the backup on eef-dev.com? Or another domain?

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘can't start backup, WPDB Error’ is closed to new replies.