Support » Fixing WordPress » cant solve the slow loading although i have 2S report on Gtmetrix

  • good day to all

    I am struggling since weeks to solve this issue, after long hard work we managed to reach less than 3 S and good ranking on Gtmetrix report, but this is not the real fact when open the page, it take more than 10-15 second loading and to start showing anything on the page while on any testing tools it give 3-5 second loading
    PLEASE Help its very challenge issue

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi, what is precisely your problem?

    Have you tried WP Fastest Cache with Autoptimize?

    https://wordpress.org/plugins/wp-fastest-cache/
    https://wordpress.org/plugins/autoptimize/

    These two plugins can help you to reduce the load time of your website. also, try to compress your images ( reduce the size of your picture ).

    Maybe some of the resources are blocked or banned in your ISP, and that’s why it’s not loading quickly.

    sign up on Gtmetrix.com and try different locations.

    Thread Starter abualdahab

    (@abualdahab)

    I am using both plugins which was very helpful,
    The problem when you open the page it take so long to start the connection and showing the content, more than 15 second some times.
    On Gtmetrix report it shows fast loading and within 3 second which is not matching the reality
    I moved to VPS server, and did all advises in the world !! still take long time

    • This reply was modified 1 year, 11 months ago by Jan Dembowski.

    My favorite tool is google page insight, I did check your website with it and this is the result :

    https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fwww.tebcare.com%2F&tab=desktop

    also I checked console on chrome browser :

    Failed to load resource: the server responded with a status of 400 ()
    (index):1 Uncaught (in promise) Yc
    autoptimize_e09e3293f5d9dec3860ad262ea3a5d9b.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
    autoptimize_e09e3293f5d9dec3860ad262ea3a5d9b.js:79 Just an info: ReferenceError: mdf_use_custom_scroll_bar is not defined
    autoptimize_e09e3293f5d9dec3860ad262ea3a5d9b.js:108 Uncaught ReferenceError: ajaxurl is not defined
    at container_serch_panel (autoptimize_e09e3293f5d9dec3860ad262ea3a5d9b.js:108)
    at HTMLDocument.<anonymous> (autoptimize_e09e3293f5d9dec3860ad262ea3a5d9b.js:106)
    at i (jquery.js:1)
    at Object.fireWith [as resolveWith] (jquery.js:1)
    at Function.ready (jquery.js:1)
    at HTMLDocument.K (jquery.js:1)
    recaptcha__en.js:517 Uncaught Error: Invalid site key or not loaded in api.js: 6LeU5Q8UAAAAAPDeZs6ztsWM1w4LhpStj7a43u-h
    at Object.NL [as execute] (recaptcha__en.js:517)
    at execute ((index):54)
    at Cn (recaptcha__en.js:521)
    at J (recaptcha__en.js:508)

    deactivate autoptimiz. Install and activate this plugin :
    https://wordpress.org/plugins/fast-velocity-minify/
    Do the settings and see if it’s working alright or not.

    before installing the new plugin, clear your cache.
    hope it will work for you.

    Thread Starter abualdahab

    (@abualdahab)

    Thanks Haamed,

    I cant activate this plugin, give the below notw
    (Fast Velocity Minify requires the PHP mbstring module to be installed on the server)

    You’re most welcome. I’m here to help.
    Ok. Let’s deactivate autoptimize and use WP Fastest Cache.
    give it a try and see how is it?

    If your website is still loading slow for you try to install and activate this plugin :
    https://wordpress.org/plugins/speed-booster-pack/

    by the way, did you update/upgrade every plugin and theme on your website?
    make sure there is no conflict between your plugins and your theme ( or with your WordPress installed on your server )

    Thread Starter abualdahab

    (@abualdahab)

    not working as well 🙁 make it worse 🙁

    i updated all used plugins

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @hamed-hosseini I have removed your reply and flagged your account temporarily. That just means that your post will need to be approved and @ notifications from you will not work.

    It is important that you never ask for off forum contact. That’s not permitted and I have archived your reply.

    Please continue to provide support here.

    • This reply was modified 1 year, 11 months ago by Jan Dembowski. Reason: Fixed sentence

    From here (Virginia, USA. A couple of hops from Nova via Charlottesville) that site loaded nicely. Do you really want more speed? Spend more money on a faster host but I’d take what I had and be happy.

    One thing you might try is adding CloudFlare in front of that host. That can speed things up dramatically but…

    the free CloudFlare tier can be impatient… if CloudFlare gets tired of waiting on things it will throw a ‘500’ error. Even then the CloudFlare distributed DNS might help a little with their proxy turned off.

    Sometimes you can pick up a bit of speed by using a CDN since you have a cache plugin if you decide to keep that.

    But seriously… I’d ignore the numbers after a point unless you really want to spend the money for the speed.

    It’s like SEO… one more customer may never pay back the investment to find him. There’s a point of diminishing returns.

    Thread Starter abualdahab

    (@abualdahab)

    Thanks alot ….
    The main issue here is the (Time to First Byte (TTFB) when you open the page its take more than 7110 second to start showing content
    i have VPS server host

    Thanks again

    haytham

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘cant solve the slow loading although i have 2S report on Gtmetrix’ is closed to new replies.