WordPress.org

Forums

Watu
[resolved] Can't show results (7 posts)

  1. xryztinf
    Member
    Posted 1 year ago #

    Hi!

    I used the free version you have of the plugin. I create a 10-question quiz where all questions are shown in a single page. Nothing is happening when I clicked the "Show Results" button when I tested it and answered the questions. The button is not even clickable.

    I will be waiting for your response.

    Thanks in advance.

    https://wordpress.org/plugins/watu/

  2. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Oh, looks like I have to ask this every single time:

    URL PLEASE!

    I must see your URL or I can't help. I am sure you have fatal javascript error on the page (caused by other plugin or your theme) but without seeing the URL there is no way I can tell you what exactly is the error and what is causing it.

  3. xryztinf
    Member
    Posted 1 year ago #

    I apologize for not putting the url and didn't mean to cause you any inconvenience.. Here it is

    http://positiveproductivity.com.au/employee-engagement-quiz/

  4. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks. As expected you have fatal javascript error on the page. There are two different jQuery versions loaded. One is hardcoded in your header and should be removed. All themes and plugins should use wp_enqueue_script to load jQuery, and not load it directly like in your case.

    I'm marking this resolved because the problem is discovered and it's not in Watu.

  5. xryztinf
    Member
    Posted 1 year ago #

    Hi there,

    I brought this concern to the theme developers and advised me to update the theme which I did. Sadly the plugin still doesn't work.

    Can you please help me with it?

    Link: http://positiveproductivity.com.au/employee-engagement-quiz/

  6. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    You still have fatal error in custom.js:

    Uncaught TypeError: Object [object Object] has no method 'flexslider'

    And this is most probably because you still have jQuery included twice in the page. And I bet this plugin "FAQ Manager" is including it wrongly, because its call is local:

    http://positiveproductivity.com.au/wp-content/plugins/faqs-manager/jquery/jquery.min.js

    Web sites should not be throwing fatal errors. The quiz will start working when you remove the fatal errors.

  7. prasunsen
    Member
    Plugin Author

    Posted 1 year ago #

    I see your issue is resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Watu
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic