Support » Theme: Blask » Can’t set static home page

  • In the past week, my home page was spontaneously sent to the Trash (I am the only person with access, and I have been out of the office). I restored it. Now I can’t set it as the home page. But I kept it so that I have a link to “home” in the menu.

    So, I decided to follow the link from the dashboard that helps me set up a post in order to recreate it. (It will now be a duplicate of the “home” page so that home appears on my menu). This new post that serves as my home page only publishes latest posts. How to I 1) make this new post a page that shows up in my menu and 2) is a static home page?

    There is no option to set it under Settings>Reading, nor Appearance>Customize.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • 1) make this new post a page that shows up in my menu

    You will need to go to your Custom Menu area within Customizer and add the home page as a menu item. You can click Automatically add new top-level pages to this menu which should get the menu added to your navigation page.

    2) is a static home page?

    Are you wanting to make it a portfolio homepage like the demo?

    https://blaskdemo.wordpress.com/?demo

    If so, you can set up the static page by following the instructions on the theme page here:

    https://wordpress.com/theme/blask

    Hope that helps. Please let me know if you have any questions.

    Thanks!

    Thread Starter gretchennewberry

    (@gretchennewberry)

    Sorry, this doesn’t help. This appears to be an ad for the Blask theme. There are no menu items called the Customizer, either.

    There are no menu items called the Customizer, either.

    I am referring to the Customizer that you can get from your dashboard: Appearance > Customize > Custom Menu:

    Are you able to get to this area from your dashboard?

    Thread Starter gretchennewberry

    (@gretchennewberry)

    Yes, but that didn’t change anything. I still have to have this post be a duplicate of the page marked Home.

    Thanks for your help, though.

    So, when you go to Settings > Reading, you are seeing the below, correct?

    If so, are you saying that your original home page isn’t an option under those two dropdowns?

    Thread Starter gretchennewberry

    (@gretchennewberry)

    No, sadly, I now only get this:
    “Reading Settings
    Blog pages show at most
    10 posts
    Syndication feeds show the most recent
    10 items
    For each post in a feed, include
    Full text
    Summary

    Your theme determines how content is displayed in browsers. Learn more about feeds.

    Search Engine Visibility
    Discourage search engines from indexing this site
    It is up to search engines to honor this request.”

    Did they change something in the settings of the Poseidon theme?

    Did they change something in the settings of the Poseidon theme?

    Ah, well that may be contributing to the issue. This is the forums for the Blask theme and I was giving you instructions based on that theme, not the Poseidon theme. Much of the dashboard is the same, but there may be some differences that I am not seeing because I didn’t have Poseidon activated.

    Please post your same question here and we can take a further look into the Poseiden theme:

    https://wordpress.org/support/theme/poseidon/

    Thanks,

    Thread Starter gretchennewberry

    (@gretchennewberry)

    My apologies! Thanks for the link. Will do.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can’t set static home page’ is closed to new replies.