• I’m administrator of internal website. I tried to set users profile picture but it stuck after crop picture it stuck at “processing” for long time and not done. But when I close the processing window, the profile picture I choose just display but in wrong resolution. I am waiting for fix this issue for more weeks but don’t have any fix. Please, fix this problem.

Viewing 15 replies - 1 through 15 (of 19 total)
  • I have the same problem…
    The situation is:
    1. I Installed WP Hide & Security Enhancer
    2. When I change WP content or Upload path using WP Hide & Security Enhancer
    3. Then go to upload profile photo, it keeps “processing” in Ultimate Member
    4. But After press F5 to refresh the page, the photo updated.

    Sometime we really need to change the WP defaut path.
    Please help to solve this problem, thanks!
    PS: Sorry for my bad English…

    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @pexza and @hulislai,

    Do you have any image optimization plugins?
    Can you please clarify what do you mean by “the wrong resolution”?
    If you are trying to upload a large image make sure that you have enough memory to process it, try increasing WP memory limit and see if it helps.

    You can also do a quick conflict test and see if this issue goes away.
    Here is the doc on how to do a conflict test if you are not sure how to do it.

    Regards.

    Thread Starter pexza

    (@pexza)

    I tried your solution to test problem of ultimate member. I disabled all plugins except ultimatemember and reverse to default theme but problem still happen. I think your plugin has problem, it happen after update to last version.

    Hi @ultimatemembersupport

    No image optimization plugins installed.
    I disable WP Hide & Security Enhancer, everything will be Fine.
    But I need to change the path of “WP content” for my website.
    Once I using WP Hide & Security Enhancer to change it, upload profile photo in Ultimate Member does not refresh automatically, it just keep “processing”…

    Everything will be Fine at the path:
    https://mywebsite.com/wp-content/upload/my-photo.jpg

    Keep “Processing” at the path:
    https://mywebsite.com/assets/files/my-photo.jpg

    WP Hide & Security Enhancer not really changed my files path, it just like add a filter.

    When press “F5” to refresh the page manually after “Processing”, the photo I want to upload has been updated successfully.

    But for my users, they only know “keep processing”, they don’t know their photo has been updated.

    • This reply was modified 2 years, 4 months ago by mofish.
    • This reply was modified 2 years, 4 months ago by mofish.
    • This reply was modified 2 years, 4 months ago by mofish.
    • This reply was modified 2 years, 4 months ago by mofish.
    Plugin Support Ultimate Member Support

    (@ultimatemembersupport)

    Hi @hulislai,

    I’m afraid, the Ultimate member doesn’t support alternative upload path.
    We will see if it is possible to add this option in the future updates.

    Regards.

    @ultimatemembersupport

    OK Thank you.
    Hope Ultimate Member to be better.

    I am having the same issue with the plugin not accepting the cropped image. After selecting the image for a profile, cover image, or gallery image the popup dialog notifies the user that it is “Processing” but, does not complete.
    This began happening after the 2.0.28 update to the plugin.
    I reported this 2 weeks ago and have not received a solution yet.
    https://wordpress.org/support/topic/profile-and-cover-photo-doesnt-finish-processing/#post-10763057

    Developer tab reports:
    admin-ajax.php {success: false, data: “Invalid file ownership”}
    data: “Invalid file ownership”
    success: false

    No conflicts with other plugins or themes.

    Thread Starter pexza

    (@pexza)

    I wait for update to fix this issue but no update and problem still happen.
    1. I uploaded user picture and stuck at processing
    2. After waiting for long time, I closed the popup window and refresh page user picture just display but in wrong resolution
    https://imgur.com/EGdOigs

    no way to fix this issue by me so please, review and fix this issue guy.

    Same here. I reinstalled my complete site (including the database). Still doesn’t work, did first.

    Yes, I have the same problem after the update–uploading a member photo hangs after the crop (upon ‘Processing…’).

    Hey — someone smart figured it out:
    ikarus76 wrote:
    Hi, it happened with me too. The problem is the directory seperator. As a quick fix you should change in the file .\ultimate-member\includes\core\class-uploader.php on line 162 the $this->core_upload_dir to $this->core_upload_url.
    regards,
    Michael

    Has this been fixed officially yet?

    line #162 is no longer that string.

    • This reply was modified 1 year, 11 months ago by GregW.

    @gwmbox I have changed line# 168 (maybe line number changed after update)
    it’s working as intended. But credit to @sehenderson for pointing out the code.

    		public function get_upload_base_url() {
    			$wp_baseurl = $this->wp_upload_dir['baseurl'];
    
    			$this->upload_baseurl = set_url_scheme( $wp_baseurl . $this->core_upload_url );
    
    			return $this->upload_baseurl;
    		}
    • This reply was modified 1 year, 11 months ago by Kalapahar.
    • This reply was modified 1 year, 11 months ago by Kalapahar.

    @kalapahar Where should I enter the function you wrote? Could you tell me the steps to follow? Thank you.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Can’t set profile picture’ is closed to new replies.