Support » Fixing WordPress » Can’t set password for new users

  • I just upgraded to 5.5.1 and now, when I tried to add a new user, there doesn’t seem to be any way to add a password for a new user? There is a button that says “Show Password” but there is to field to enter the password?

Viewing 15 replies - 46 through 60 (of 66 total)
  • Just tried it in Chrome browser and it works fine – I was using Firefox previously.

    same here @scalarent
    firefox was the culprit
    used Brave browser and bingo!

    Hi all,
    I had also this problem
    – can´t generate a new password
    – clicking button doesn´t show the password
    – can´t add a new user and so on…

    I had some day earlier installed a password manager – I closed it and problem was solved. Perhaps LastPass Password manager has the same effect.

    shanekeller

    (@shanekeller)

    Having the same issue. I cannot add new users because of this error nor can I update a password because of this error:

    “Error: passwords don’t match. Please enter the same password in both password fields.”

    @scalarent same issue for me, was using Firefox, didn’t work. Tried chrome, worked fine.

    Firefox

    • Not working
    • Hide button does nothing
    • Generate password fixes nothing
    • Just 1 password field
    • Password field comes filled ( probably catching some login saved )
    • Error both password should match

    My guess,
    the second field is hidden and should not be.
    Tried

    Deactivating Wordfence solved this problem for me

    Same problem for me. Using Safari on macOS Big Sur.

    I own several sites in different environments (WP versions, plugins, themes). Everywhere the same problem since this afternoon. I also tried on a Windows 10 with Edge. Even in a site I have not updated for months it’s not possible to add a user.

    Adding a new user does not show the second password field. Also when you sent an email to reset the password the change-password window does not show you the second password box.

    Search the internet for solutions. But not found so far.

    So please help…..

    Eef

    Didn’t work on Firefox but worked on Chrome.
    However on Firefox, when I opened the Web Developer tool (F12) and went to the Add New page, it worked every time I did this. Strange.

    On Console, I also saw some errors like this:

    jQuery.Deferred exception: r is undefined f@https://....../wp-admin/js/user-profile.min.js:2:180
    v@https://....../wp-admin/js/user-profile.min.js:2:1185
    @https://....../wp-admin/js/user-profile.min.js:2:5069
    e@https://....../wp-includes/js/jquery/jquery.min.js:2:30038
    l/</t<@https://....../wp-includes/js/jquery/jquery.min.js:2:30340
     undefined jquery.min.js:2:31593
    Uncaught TypeError: r is undefined
        f https://....../wp-admin/js/user-profile.min.js:2
        v https://....../wp-admin/js/user-profile.min.js:2
        <anonymous> https://....../wp-admin/js/user-profile.min.js:2

    Hi WRIP,

    Thanks for your information. Most of my sites are WP 5.8.
    I opened in Safari the ‘Show console’.
    When I add a new user I see:
    JQMIGRATE: Migrate is installed, version 3.3.2

    jQuery.Deferred exception: undefined is not an object (evaluating 'r.data') (2)
    f — user-profile.min.js:2:195
    v — user-profile.min.js:2:1187
    (anonieme functie) — user-profile.min.js:2:5071
    e — load-scripts.php:2:30044
    (anonieme functie) — load-scripts.php:2:30342

    I did the same with one of my sites with WP 5.7. It does not show the error there.
    So my conclusion is it has something to do with the WP 5.8 version.

    For clearness maybe: I tested this on several machines: macOS Big Sur and High Sierra, Windows 10

    I installed plugin ‘enable-query-migrate-helper’ With this plugin you can enable the use of JQMIGRATE 1.4.1 again. With that I am able to add new users and a user can assign his own password with the link in the email.

    But this is just a temporary solution I hope…..

    Eef

    I have solved this matter deactivating Wordfence.

    I had to same issue. It’s not WordPress, it’s your browser. Try using a different browser to create a new user. I was using Firefox.

    Jack Meyer

    (@cadjewelleryskills)

    Hello:

    I’m having a similar issue, but more widespread, and I’m wondering if anyone could help.

    I had some problems logging in a while ago, and I think I tried the wrong password too many times. After that, none of my WordPress accounts would allow me to log in. I couldn’t log in, change my password, nothing. It didn’t matter which browser I used, or if I changed my password from the web host admnin backdoor access.

    Insanely enough, the tech support guys from my web host can log in with my credentials without problems!

    Now, today, a colleague sent me a registration site for an account on his wordpress blog in a different host and site. It wouldn’t let me create a new password, or log in with the password set by my colleague.

    Has WordPress or their spam blocker somehow blacklisted my IP address? And if so how do I fix it?

    Same problem here, everything up to date on WordPress 5.8.1, . “Error: Passwords don’t match. Please enter the same password in both password fields.” Cannot generate a new password. The hide-unhide password button doesn’t work either.

    When disabling “Wordfence Security” Plugin then it working.

    • This reply was modified 1 month, 4 weeks ago by ejoybiswas.
Viewing 15 replies - 46 through 60 (of 66 total)
  • You must be logged in to reply to this topic.