WordPress.org

Forums

Can't set Featured Image (8 posts)

  1. modelcitizen
    Member
    Posted 3 years ago #

    Hi,

    I'm trying to set up a theme where 'featured images' are really important to the look.

    Unfortunately I don't seem to be able to set the featured image.

    I can see the 'set featured image' link bottom-right in the dashboard, but when I click it opens up the usual dialogue box for adding an image into the post, but doesn't include a 'set as featured image' link. So it only adds the image to the post as a regular image, not featured image.

    this is really frustrating - I've tried using the twentyten theme, but same problem.

    Any suggestions?

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  3. ammarasfour
    Member
    Posted 3 years ago #

    Hi -
    I 've tried all above. Yet, I still don't see the option of set feature image. Any help?

    I can see the initial link. But the pop-out window appears. I only see the insert into post button. I don't see the link that says set as feature.

  4. modelcitizen
    Member
    Posted 3 years ago #

    hi - yes - I've tried all of the above and still no luck.

    just to confirm the problem.

    in the dashboard, the link 'set featured image' IS available, but when I click on this and upload an image or enter a URL the only option I have available is to 'insert into post' there is no link visible to 'set as featured image' (which there should be from everything I've read).

  5. modelcitizen
    Member
    Posted 3 years ago #

    Ok have found solution - my 'media' folder wasn't writeable by the server.

    As soon as I chnaged permissions on that folder, the link showed up.

  6. ammarasfour
    Member
    Posted 3 years ago #

    Hi - this is stupid, but what's the Media folder named? I can't find a folder titled Medial in my Files Manager through my cPanel.

    Or is it something i need to do through the WP dashboard?

    I had just un-installed WP and re-installed again. Now, I am running into different issues:
    1- the "Set as featured image" does not appear when I try to input a URL but appears when I try to upload from computer.
    2- even if I upload from computer and set as feature. It does not seem to actually do anything with it. And all the themes that should use the Feature Image are not picking that image up.

  7. modelcitizen
    Member
    Posted 3 years ago #

    you need to set the media folder yourself...

    in the sidebar go down to settings--> media and under UPLOADING FILES you specify the name and location of the folder on your server where you want workdpress to store uploads. the default is wp-content/uploads but WP doesn't automatically create this folder - you need to do it manually and then set permissions on it to 777 or whatever through your cpanel.

  8. strikeengine
    Member
    Posted 3 years ago #

    modelcitizen - you are a model citizen, just the answer i was looking for

Topic Closed

This topic has been closed to new replies.

About this Topic