Support » Plugin: Elementor Page Builder » Can’t set Elementor’s built page as a static home page

  • Resolved dameer.dj

    (@dameerdj)


    Hi,

    already wrote about the issue but at the wrong place (WPCrafter.com) since there’s no answer yet. And, of course, I was wondering how come no one out of 700.000+ users have noticed it yet.

    So, just as the title reads, there’s no way to set up Elementor composed page as a static home page which doesn’t make any sense. It simply doesn’t show up on the list of available pages under Settings > Reading :: Your homepage displays.

    Hopefully someone might provide some sort of solution!

Viewing 7 replies - 16 through 22 (of 22 total)
  • patrickswackyhouse

    (@patrickswackyhouse)

    That is not working either. Firstly: making a new page the regular way always gives a default header that, i don’t want. Secondly: its not loading it now anyway. Thirdly: there is already a fully built page in Elementor, that, i really really feel i should be allowed to make into a real actual page. I’m giving this a chance because of all the hype over how vastly Superior this is to “hard coding”, but, i’m not seeing it. Every time it looks like things are going easy, some option is missing, or, something goes wrong, or, i supposedly did something wrong because, the interface is totally not intuitive and ass backwards. I’m reading these support threads to: find the answer to something i thought would be really super easy. I must just not know where the button is, or, i missed something minor, and, i will have this thing published in no time, but, i should really stop myself from that way of thinking in WP , because, its always a setup to utter disappointment. E v e r y t h i n g will always be some kind of extensive process, or, hidden in a completely different section or option than first instincts or it was flat out impossible to ever do, and, i should feel a fool for trying it.

    tmledu100

    (@tmledu100)

    Please help i’m having the same issue as well.

    At the Setting – Reading Setting – THere is no Home Setting. Pls help…

    Same problem here. I can open the page via the elementor template, but when I go to try and set it as the homepage, it doesn’t show up on the list.

    DigAng

    (@digang)

    Same problem and I’m so frustrated trying to problem solve this! Seems like a very simple, but crucial oversight. You hit “publish”, but to where? You can even name the page, but the page never shows up in your list of pages! Ugh. Please, can anyone help?!

    moha9538

    (@moha9538)

    All,
    Please delete/uninstall/deactivate some of your plugins. Mine worked that way.

    DigAng

    (@digang)

    I finally resolved this problem. What worked for me was to:

    1. save my elementor page as a template

    2. create a new wp page and publish it right after just creating the title

    3. edit the newly created page with “edit with elementor” option

    4. import the saved template by clicking the middle folder button on the first element

    Easy to do… hard to figure out! Ugh. What a nightmare after spending hours trouble-shooting this. I really hope this helps someone else!

    namelessmember

    (@namelessmember)

    This helped me solve it:
    1) Make sure that you first create a page that has a ‘Slug’ and that it has the status ‘Published’
    2) After then you might be able to find the following:
    Settings > Reading > Your homepage displays: A static page (select below) > Homepage: ‘<Pagename>’

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘Can’t set Elementor’s built page as a static home page’ is closed to new replies.