• Resolved BruceInLouisville

    (@bruceinlouisville)


    Hello! I have d/l and installed the Sucuri plugin. On the Settings tab, it is using a path of

    /data/www/demo.designwall.com/public_html/dw-focus/wp-content/uploads/sucuri

    I have added a line to my wpconfig file to define a different data path, but it apparently is either incorrect or not having any effect. And of course, if I check the “File” checkbox, I get an error about the path not being writeable. (Since it is for a completely different domain. <g>)

    I do not see any way to change the path from within the plugin, and my attempts to change the path through wpconfig have failed. Thoughts?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Anyone?

    Still need help here.

    Uhm — sorta disappointed in the lack of response here. Is this indicative of the support received by users of the plugin?

    I had the same problem with the data path after moving to a new server. Please try this as a workaround.

    Sucuri on my site writes to a folder, wp-content/uploads/sucuri. The settings would be stored in a file called sucuri-settings.php

    First, make a backup of all the files in wp-content/uploads/sucuri.

    Update the sucuri-settings.php file by changing the “sucuriscan_datastore_path” value to the new absolute path to that same ‘sucuri’ folder.

    Example:
    OLD: “sucuriscan_datastore_path”:”\/var\/sites\/path\/to\/old\/public_html\/wp-content\/uploads\/sucuri”

    NEW: “sucuriscan_datastore_path”:”\/home\/path\/to\/new\/public_html\/wp-content\/uploads\/sucuri”

    Visiting the Sucuri settings in WP admin, I saw that the changes were immediate.

    Hope these help!

    Thank you for responding! Your response made me re-think the problem, as I did not have ANY folders showing sucuri content. That made me wonder if this was actually a failed install.

    So, I deactivated, deleted, re-downloaded, re-installed, and re-activated. Voila! All was well.

    Thank you, again, for your help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can’t set data storage path’ is closed to new replies.