Support » Plugin: WooCommerce » Can’t set any images in product post

  • Resolved jeremymoncur

    (@jeremymoncur)


    I’m using WordPress v 5.6 and the Astra Pro Theme. I have updated and reinstalled both and done the same with the Woo Commerce Plugin. I’ve also disabled all plugins except for Woo Commerce and switched to the market place theme all at the same time. No luck.

    The product image link allows me to select an image but doesn’t show up on the edit product page after or on the front end product page after saving. When I assign the gallery photos, they show up in the edit product page, but disappear once I save the page:

    https://drive.google.com/file/d/1Y1Mar5Yq5Voz789T-pETNKEblmLjafvk/view?usp=sharing

    No images can be added in the main edit product editing window or the Product Short Description window either.

    Images upload fine in the visual posts and pages editor.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Hey there,

    Thanks for all of the testing so far!

    When you say you switched to the “market place” theme, which one do you mean?

    For the record, this kind of problem is usually caused by either a conflict with your theme or with another plugin.
     
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    Thread Starter jeremymoncur

    (@jeremymoncur)

    Hi Hannah,

    So sorry. Storefront theme is what I meant to say. So, I had completed everything and still no luck.

    However, with your advice I did everything again and when I tested adding the image to the edit product page, I used a new image I had uploaded and it worked fine. I’m doing this on a staged website and realize that when I use any of the images that were carried over from the original site, it doesn’t work. Still not sure why that is but the only different I notice is that when I select one of those older pics there’s no file dimensions or size info on any of them.

    So, anyway, the theme and plugins all work fine it was the old pics for some reason.

    Jeremy

    Thread Starter jeremymoncur

    (@jeremymoncur)

    Resolved!

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    I’m glad to hear you solved it! Thanks for letting us know and good luck with those images.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.