Support » Plugin: WP SMS » Can’t send sms with SMSGlobal

  • Resolved Phuc Pham

    (@svincoll4)


    The gateway status is always Deactivated even I generated the new API key and my account balance is $75.
    I have dumped the error, it says:
    “Authorization header is empty or format is incorrect”

    File: plugins/wp-sms/includes/gateways/class-wpsms-gateway-smsglobal.php
    See: https://d.pr/free/i/BPLcdO

    Could you please check it?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Mohammad Ghasemi

    (@ghasemi71ir)

    Hello @svincoll4

    This issue fixed on the new version, today we will release it.

    Best Regards.

    Thanks,

    The gateway status is now Active.
    But I still cannot send the SMS, it says: Destinations is invalid.
    Please could you check again?

    Plugin Contributor Mohammad Ghasemi

    (@ghasemi71ir)

    Dear @svincoll4

    Check receptions on the log on your “WP-SMS > Outbox” and see the destination numbers are valid or not?

    @ghasemi71ir This is the log:

    stdClass::__set_state(array( 'errors' => array ( 0 => 'Number \'AU614315xxxxx\' in Destinations is invalid.', ), ))

    I guess the country code AU caused this error. Please remove the country code AU.

    Plugin Contributor Mohammad Ghasemi

    (@ghasemi71ir)

    Dear @svincoll4,

    We did not put the country code in the plugin!
    You can the country code from the: “WP-SMS > Settings > General” and it must be a number with plus character, like this:
    “+1”
    It will add the “+1” country code to every number on sending SMS.
    Maybe you put the “AU” as the country code number!

    Best Regards.

    @ghasemi71ir

    Yes, you are right. I has put the ‘AU’ in the country code setting for two years and it was still working good until recently. So strange!!.
    I have just removed it. It should be empty because the SMSGlobal do it automatically.
    Anyway, thank you very much.
    This is resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t send sms with SMSGlobal’ is closed to new replies.