Support » Plugin: Loco Translate » Can’t select strings

  • Resolved kiwihawk

    (@kiwihawk)


    I cannot seem to select the English string at the top. I click on it and nothing happens.

    If I use the filter translation box it comes up with the strings, but they too are not able to be selected and the second box says “Source text not loaded”

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Tim W

    (@timwhitlock)

    I can’t say what is wrong based on this description. Try disabling other plugins to find if something is interfering with Loco Translate’s code.

    Thread Starter kiwihawk

    (@kiwihawk)

    I hope this will explain a little better.

    pic of error

    In this screen shot I have typed the word EXIT into the Filter Translation box. And it has returned two strings.
    But neither of those strings can be clicked on (as in they don’t appear to be like a link) and the next box down says ‘Source text not loaded’

    I have no other plugins active.

    Thread Starter kiwihawk

    (@kiwihawk)

    Something I have found. If I click on the source button at the top and then go back to the editor, it does put the next string at the top of the list into the second box.
    I can’t select any other string.

    error pic #2

    I can then add a translation and save it. I then get the result ‘OK: PO file saved and MO file compiled’
    I then need to do the same thing again, source button, editor and then the next string in the list will drop into place.
    But with a 1,069 strings, it’s going to be a very long job! Especially when there are only about 10 I want to change!

    Thread Starter kiwihawk

    (@kiwihawk)

    I also loaded the plugin into a different website with the same result.

    I have tried translating different languages but that doesn’t help either.

    @timwhitlock I am more than happy to allow you access to the admin of the website if you think you would like to have a go and figure out where I am going wrong.
    Just let me know how I can get the login credentials to you securely and I will make it so.
    Thank you so much for all your help.

    Plugin Author Tim W

    (@timwhitlock)

    Debugging your site is beyond the level of support available.

    I am not aware of any such bug and cannot reproduce your error. Nobody else is reporting this error, so whatever is happening it is likely very specific to your precise situation, and that may include other plugins you are running.

    As I said in my first reply: Try disabling other plugins to find if something is interfering with Loco Translate’s code.

    Thread Starter kiwihawk

    (@kiwihawk)

    I have no other plugins installed.

    Plugin Author Tim W

    (@timwhitlock)

    I can’t explain how such a fundamental function of the editor would not work for you if nothing is interfering.

    Are you sure the plugin was installed properly with all of its files intact?

    Are you sure there is nothing whatever that could affect its behaviour? Browser extensions? Ad blockers? Security software?

    Nobody else is reporting this issue, so unless you can provide steps to reproduce a bug I can’t offer a solution.

    Thread Starter kiwihawk

    (@kiwihawk)

    I have found the solution!!

    I can’t seem to use the Loco Translate plugin if I am using the Chrome Browser because as I said earlier the strings cannot be selected.

    But if I change over to using the Firefox browser, then the plugin works as expected.

    So I followed this up by turning off all the browser extensions in Chrome and then turned them back on one by one.
    Turns out that the problem is with one particular extension called “Simple Allow Copy”

    That is now permanently turned off and Loco Translate is working just fine.

    Plugin Author Tim W

    (@timwhitlock)

    Turns out that the problem is with one particular extension called “Simple Allow Copy”

    Thanks for this update.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.