Support » Plugin: Gravity Forms Quantity Limiter » Can't select fields

  • Resolved katootje


    Hi, I installed the plugin but am not sure what to do. I do something wrong because I can’t select a field in the limiter.
    I tried both:
    – adding a productfield to my form – leave the quantity option unchecked.
    – adding a porductfield to my form, checked the quantity option and added a seperate quantity field.
    But whatever I try – I can’t select a field.

    Is there a installdocumentation for dummies? I probably need one 😉


Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author B Hays


    Hi Karin,

    The first of your two options should have worked.

    Are any additional errors displayed when trying to select a field? Sometimes there are some conflicts with other plugins and it will cause the little spinner to spin forever.

    There aren’t any additional instructions, but I’d be happy to try and walk you through things. Can you export your form and put the XML file somewhere via Dropbox or the like?

    I get no errormessages. There are simply no fields to select.
    At this moment I tried the original code of this plugin in my functions.php and that works.. but the plugin is easier for my client. I can manage with just the code..but I hope I get the plugin to work. I can put the file somewhere. do you have a mailaddress to send it to? It’s just a trial form, so the file is very small.. just two product 😉

    Plugin Author B Hays


    What version of Gravity Forms are you using?

    Email your XML to benhays AT gmail and I’ll have a look.

    Hi, I have the same problem. We are using WP 3.8.1 and Gravity Forms Version 1.8.5.

    Have you ever thought to limit the fields directly within the field like in

    Plugin Author B Hays


    Does the little spinner spin forever?

    It’s possible there is a conflict with another theme, so you may try disabling other themes to see if that is the case.

    I have not thought about adding the fields directly to the field. That looks like a decent solution, however, for my needs, the current setup works fine. If you’d like to extend the plugin, you can submit a pull request on Github:

    Hi there,

    New user to WordPress and the Gravity and Quantity Limiter plugin here, but I also cannot seem to get it to work.

    Created a test form with a single product field … but cannot select the field in the quantity limiter

    <?xml version="1.0" encoding="UTF-8"?>
    <forms version="">
    	<form labelPlacement="top_label" useCurrentUserAsAuthor="1">
    		<title><![CDATA[Testing products and pricing]]></title>
    		<button type="text">
    			<field id="1" size="medium" type="product" inputType="singleproduct" enableEnhancedUI="1">
    				<label><![CDATA[Enkelproduct 1]]></label>
    					<input id="1.1">
    					<input id="1.2">
    					<input id="1.3">
    				<basePrice><![CDATA[27,00 €]]></basePrice>
    						<text><![CDATA[Eerste keuze]]></text>
    						<value><![CDATA[Eerste keuze]]></value>
    						<price><![CDATA[15,00 €]]></price>
    						<text><![CDATA[Tweede keuze]]></text>
    						<value><![CDATA[Tweede keuze]]></value>
    						<price><![CDATA[27,00 €]]></price>
    						<text><![CDATA[Derde keuze]]></text>
    						<value><![CDATA[Derde keuze]]></value>
    						<price><![CDATA[31,00 €]]></price>
    			<field id="3" size="medium" type="option" inputType="checkbox" productField="1" enablePrice="1">
    						<text><![CDATA[Eerste optie]]></text>
    						<price><![CDATA[1,00 €]]></price>
    						<text><![CDATA[Tweede optie]]></text>
    						<price><![CDATA[2,00 €]]></price>
    						<text><![CDATA[Derde optie]]></text>
    						<price><![CDATA[3,00 €]]></price>
    			<field id="4" size="medium" type="total">
    			<confirmation id="5355734cbdcb2" isDefault="1" type="message">
    				<name><![CDATA[Default Confirmation]]></name>
    				<message><![CDATA[Thanks for contacting us! We will get in touch with you shortly.]]></message>
    			<notification id="5355734cbcd0f">
    				<name><![CDATA[Admin Notification]]></name>
    				<subject><![CDATA[Nieuw aanmeldformulier {form_title}]]></subject>
    Plugin Author B Hays


    Hi Bascy,

    I discovered that the fields were not displaying because the label is not set to ‘Quantity’. This is obviously an issue for any non-english setups.

    I’ve adjusted the code to check on field number instead of label, so you should be good to go. A new version should be in the repository shortly.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can't select fields’ is closed to new replies.