Support » Installing WordPress » Can’t select database – Have to be on root?

Viewing 7 replies - 1 through 7 (of 7 total)
  • It is always about human error in not putting the right info into the wp-config.php file.

    As to your question: you can install WP in a subdir without any problem, provided the config file is correct.

    This is the only part of the config file of which I’m unsure

    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    Do I need to change that since it is in a subdir?
    What if my domain ( is managed through a different domain ( with files found here: /public_html/seobrien

    Thanks alot

    The location of the database server and the location of your WP files have nothing to do with each other!

    If you are unsure about the “localhost” contact your host company.

    I repeat, and don’t ask it again: it doesn’t matter where do you install WP, in a subfolder or root. What matters is to have the 4 pieces of info correctly in the config file.

    wow. appreciate your support but is the tone necessary? Your first answer was this “As to your question: you can install WP in a subdir without any problem, provided the config file is correct.”
    To someone unfamiliar with databases vs. the installation, you told me that I can install the files where ever I want but did not clarify if the database location needs to address the fact that I’m in a subdir. I sincerely appreciate your help but my asking it (again) was very intentional as my question wasn’t answered the first time.

    Can I ask another, different question?
    I’ve finally accessed the install pages and when trying to login, with the right username and password (I’ve done it now 3 times by deleting the DB tables and reinstalling), I get this error:

    You don’t have permission to access /wp-admin/ on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Do I need to use MySQL database user and password and not those WP set for me? Are there settings I need to change on the DB? Read/Write permissions?

    Thanks again

    The tone is not necessary… just provoked by users who don’t read carefully and ramble without knowing what they are talking about. Sorry.

    Liek in your post above. Don’t assume you know where to look for the answer. Just ask. E.g. in your post above – put the error message there and stop being “smart” asking questions about the database. The error message does NOT say anything about your database, so don’t even mention it. It is about file permissions. Files and database are two different things.
    If you managed to install – leave the database alone, for God’s sake!

    Take care of the file permissions! > ftp > chmod… (keywords for search)

    Alright man, let me share the same suggestion. Don’t assume all the questions asked are by idiots. I’m pretty good with the file structure, permissions, etc. to make a good bet that the problem isn’t there. Now, I may be wrong as I have no experience with DBs so that is why I keep referring to it with my questions; I am assuming that is the problem. If it isn’t, a little more help is appreciated rather than badgering me for my question.

    The error message isn’t telling me anything of value about the installation, database, or heck my operating system (that’s sarcastic).
    All the permissions on wp-admin, subfolders, and files are open (777) so the error doesn’t make sense to me with my limited knowledge. As far as I know, I shouldn’t be getting a permission error when all the chmod settings are read/write/execute for user, group, and others.
    What am I missing?

    This is what I did when I had the same problem with the 403.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t select database – Have to be on root?’ is closed to new replies.