Support » Fixing WordPress » Can't Select Categories – Major Issue with Posts

  • My installation was working fine a few days ago.

    For some reason now whenever I try to choose a category for a post, after clicking save the categories are not added to the post.

    If I save a post and try to add a category to it afterward, it still doesn’t save.

    I turned on debug mode and there are no errors coming up.

    If I simply add in a row in the wp_term_relationships table with object_id as the post and term_taxonomy_id as the category id, the category is added fine.

    What is causing this? My client can’t use the installation. I’ve tried everything, including updating wordpress. I’ve searched online for a really long time and I can’t find anything.

Viewing 2 replies - 1 through 2 (of 2 total)

    This is the same issue I had that didn’t get any response either if it better describes the problem.

    Does anyone have any ideas what this could possibly be?

    So this is going to end the way most of these things end.

    I’ve just resolved this.

    I had a custom made plugin that I was using on this wp installation. Because the plugin was central to the site I only deactivated every other plugin but this one in my tests.

    Finally upon deactivating it – I found that was the source.

    I was filtering the inputs universally in the main plugin file. (cleaning up ALL $_POST and $_GET using a foreach) There was my mistake. I guess the plugin system is called before the category management system is invoked in the admin ajax processing so it was filtering the inputs and not allowing me to add or change categories for posts.

    Anyway for future reference people who are working with custom plugins (I guess this is a given to most people) don’t filter input on the main plugin file because it affects the inputs for the entire wordpress installation.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't Select Categories – Major Issue with Posts’ is closed to new replies.