WordPress.org

Forums

WP Super Cache
Can't seem to remove query strings (4 posts)

  1. jamminjames
    Member
    Posted 1 year ago #

    Website speed testing with pingdom.com says: "Remove query strings from static resources."

    I have "Don't cache pages with GET parameters. (?x=y at the end of a url)" chosen in the Advanced tab, which I would think would take care of that. However, pingdom continues to give that same notice.

    Is that option just not working, or what? Also, I'm curious, why is it not marked as "recommended" by Super Cache?

    Thanks.

    https://wordpress.org/plugins/wp-super-cache/

  2. Losmi
    Member
    Posted 1 year ago #

    I too wish to know how to battle this "Remove the query string and encode the parameters into the URL" message I get on gtmetrix.com. Option "Don't cache pages with GET parameters" is disabled at my site...

  3. optimus203
    Member
    Posted 7 months ago #

    Was this issue ever resolved? I'm getting the same issue. Disabling the Don’t cache pages with GET parameters. (?x=y at the end of a url) option doesn't do anything for me.

  4. churva
    Member
    Posted 7 months ago #

    I use https://wordpress.org/plugins/wp-version-in-query-string-modifier/
    to remove JUST the 'ver' query string param. YOu may want to check that as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic