Support » Fixing WordPress » Can’t see uploaded images in 2.1

  • I start a new post and upload a new image using the upload tool below (Browse) the editor. When it is uploaded, it switches to the Browse Images part normally; but it is empty below the header, no image can be seen as uploaded. When I clicked on Browse All, I saw that there are some images left from the 2.0.5 version, and there’s one more page has been added. When I clicked the new page’s link, a message is displayed:”There is no attachment to be displayed.”

    Furthermore, when I look at the wp-content/uploads/2007/01 dir, I can see that the files I tried to upload were uploaded and thrumbnailized. So what can be the problem? I get the same result for firefox and konqueror.


Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having the same problem… I see the directories and images have been uploaded, but there is nothing in the Browse All section of the uploads section…

    Please, any help?

    Best guess is that the directory permissions were set to 655 when you uploaded the new files. chmod the uploads directory back to 777 and it should be ok. You might delete the entries that aren’t showing now since they actually only exist in the database (what you are seeing) and not the actual image.

    No… I think you misunderstand…

    The system actually uploaded the files… they exist… I can browse the ftp directory to them and see both the created thumbnail and the actual picture… The database shows the records for the files, pointed to the right location, etc.

    It’s just that the system shows nothing in the Uploads section, in either the Manage or Post section.

    What is the ‘chmod’ value, 644?
    Did you check the image url against what it should be (based on your ftp listing)? You may or may not be able to get the edit link, it also shows there but you can’t edit it.

    chmod for the upload directory and its sub-directories is 777…

    here’s a direct link from the db entry… it goes straight to the image… so the directory structure is correct…


    Alright, I think I have a bit more info to go on now…

    I viewed source on both of the Browse All pages, the page is cut off just after <div id='upload-content' class='browse-all'>… That’s the end of the pages…

    In the upload.php file, this is just before it calls call_user_func( $wp_upload_tabs[$tab][2] );

    Now I’m trying to dig through the code in the upload-functions.php to see if I can see anything that just stands out that would cause early page termination, but since I’m just a begginer at some of the js stuff, it’s a little greek to me.

    I was hoping someone else might be able to see what I’m missing faster…

    For reference purposes i’m running:

    WP 2.1.3
    PHP 5.1.0RC1
    MySQL 4.0.25

    Ok, I found the answer… kind of…

    This article shows that the version of php can cause blank pages. I lowered the php version from 5.1 to 5 and all the images previously uploaded showed up. Hope this helps the original poster and anyone else running into this problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t see uploaded images in 2.1’ is closed to new replies.