• Resolved karnabal

    (@karnabal)


    Hello,

    I translated the plugin in French with Poedit. I put gdpr-fr_FR.po and gdpr-fr_FR.mo files in wp-content/languages/plugins/ and I don’t see any translated strings on my website. Can you please tell me how I can translate this plugin in French?

    Thank you!

    • This topic was modified 5 years, 10 months ago by karnabal.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Bonjour,
    La traduction se fait automatiquement, mettre un fichier .po n’est pas utile.
    Depuis septembre 2015, il est possible d’éditer les fichiers de traduction directement en ligne. Ce sont eux qui sont mis à jour automatiquement lors des mises à jour de WordPress.
    Cette fonctionnalité permet à chacun de contribuer facilement au projet WordPress en proposant la traduction française pour une extension.
    Les Project Translation Editors (PTE) valident les propositions qui répondent aux critères de la langue.
    Pour info, voici l’équipe Française: https://make.wordpress.org/polyglots/teams/?locale=fr_FR
    Concernant l’extension GDPR, les traductions sont ici.
    Elle est traduite à 100% pour le Français, bien que, comme nous sommes en phase de développement, cela change tous les jours.
    Installer l’extension est donc suffisant pour que le fichier Français s’installe automatiquement.
    Bonne journée.

    Thread Starter karnabal

    (@karnabal)

    Bonjour,

    Merci pour cette réponse Bonaldi. Toutefois, pourquoi deux éléments : Privacy Preferences et I Agree, sont toujours en anglais ?

    https://prnt.sc/jwl4aw

    Thread Starter karnabal

    (@karnabal)

    Je dois ajouter qu’en fait, j’ai traduit mon thème, et que dans les réglages, je choisis montheme-fr_FR et non Français. C’est de là que vient le problème. Comment le résoudre ?

    I must add I translated my theme. In settings, I have chosen montheme-fr_FR and not Français. The problem comes from this. How can I solve it?

    Maybe you could try to clean your browser cache.
    Or it may be a cache plugin problem.
    I don’t understand why you choose your theme language in settings, instead of French.

    Thread Starter karnabal

    (@karnabal)

    I don’t understand why you choose your theme language in settings, instead of French.

    Because I wanted to translate the theme. It might not be the right way to do it, but it’s the only way I’ve found to translate the theme. If I don’t select montheme-fr_FR the theme is in English. Do I have to choose between the theme translation and the plugin translation?

    Clearing browser cache doesn’t solve the problem. I don’t use any cache plugin. 🙁

    • This reply was modified 5 years, 10 months ago by karnabal.

    Tu ne procèdes pas de la bonne manière pour traduire ton thème.
    Tu dois ajouter tes fichiers de traduction fr_FR.po et fr_FR.mo dans un dossier du thème, par exemple “languages”, et rajouter dans fonction.php le code qui appelle ta traduction.
    Par exemple :

    
    		// Rend le theme traduisible
    		load_theme_textdomain( 'tontheme', get_template_directory() . '/languages' );

    You do not do the right thing to translate your theme.
    You have to add your fr_FR.po and fr_FR.mo translation files in a folder of the theme, for example “languages”, and add in function.php the code that calls your translation.
    For example

    
    		// Makes theme translation ready
    		load_theme_textdomain( 'yourtheme', get_template_directory() . '/languages' );
    Thread Starter karnabal

    (@karnabal)

    Ah! Merci Bonaldi. Ta réponse est très claire. Merci ! Et ça fonctionne. 🙂

    Wow! Thank you Bonaldi, your answer is very clear, thank you. It works! 🙂

    Pas de quoi. 😉
    You’re welcome. 😉

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can’t see translation in French’ is closed to new replies.