Support » Plugin: WP Trip Summary » Can’t see the form on any post

  • Resolved melanubis

    (@melanubis)


    Hi !!
    I installed the plugin but can’t see any of the forms when adding a post, any idea?
    Many thanks

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Alexandru BOIA

    (@alexandruboia)

    Hello,

    If you are using the Classic Editor, there should be an “Edit Trip Summary” button, next to the “Add media” button.

    If you are using the Block Editor, then, indeed, there is no button to show, since it’s not compatible, so to speak.
    The first version that will also provide integration with the Block Editor is 0.2.4, which is, I hope (since I am waiting for some translations), no more than a couple of days away.

    You can see here the progress that’s being made on the plug-in, as well as what’s planned.

    Regards,
    Alex.

    Plugin Author Alexandru BOIA

    (@alexandruboia)

    Hello,
    I’ve update the plug-in and it now includes a way to launch the editor form for block editors as well.
    Could you please check and see if you can now do so?
    Regards,
    Alex.

    Thread Starter melanubis

    (@melanubis)

    Great to hear !! Ill give it a try asap
    Many thanks

    Thread Starter melanubis

    (@melanubis)

    Hi
    I did give it a try and unfortunately same than before, can’t see the editor form. FYI I’m using a pluing for tracks called Waymarks , could it be a compatibility issue?
    Thanks !!

    Plugin Author Alexandru BOIA

    (@alexandruboia)

    Hi, I’ve just installed Waymark, and there doesn’t seem to be a conflict to the extent that no visual cue is displayed for WP Trip Summary.

    However, just to confirm the basic things, here are two screenshots, that demonstrate what elements you should be looking for to start editing your trip summary. These are displayed in the right hand sidebar of the post editing screen.

    If you can’t see anything like this anywhere in the sidebar, could you please confirm for me that the plug-in is active? Navigate to Plugins -> Installed plugins in the WordPress admin panel and search for “WP Trip Summary” and see if it’s active (it should display “Deactivate” right beneath its name). If it’s not, then attempt to activate it and see if there’s any error being displayed. If it is, would you please copy and paste that here so I could have a look?

    Alas, if all these basic checks fail to render any clue, we could setup a TeamViewer session if that’s OK with you, because I find it rather intriguing.

    Thanks,
    Alex.

    Thread Starter melanubis

    (@melanubis)

    Hi Alex,
    It works I can see it and works as expected by I can confirm that as soon as I activated Waymark does not work and I can add any new map so seems there is some kind of conflict bnetween the two . Please let me know if you think is worth to investigate any further happy to do so
    Best regards and thanks

    Plugin Author Alexandru BOIA

    (@alexandruboia)

    You know, this does puzzle me so I’d like to investigate a bit further, especially since I’d like it to be as nonrestrictive as possible. Could you please send me, for starters, a screenshot of your post editing screen with Waymark activated and a bit of versioning: WP version, Waymark version and so on.
    Much obliged,
    Alex.

    Plugin Author Alexandru BOIA

    (@alexandruboia)

    I think I may have misunderstood your issue. Is it the Waymark map editing form you are talking about? Like this: https://imgur.com/a/77Uor2G

    Thread Starter melanubis

    (@melanubis)

    Yes, exactly
    some print screens https://imgur.com/a/omd0rjl

    • This reply was modified 1 year, 9 months ago by melanubis.
    • This reply was modified 1 year, 9 months ago by melanubis.
    • This reply was modified 1 year, 9 months ago by melanubis.
    Plugin Author Alexandru BOIA

    (@alexandruboia)

    @melanubis thank you for bearing with me on this one.
    I managed to find the cause as well: both Waymark and Wp Trip Summary are using Leaflet JS and while this itself is not a problem, it does cause some issues with Waymark’s initialization. It could have affected Wp Trip Summary itself as well, though, had some sequence of events been just a bit different.
    At any rate, since I can see there’s no reason these two (or other) plug-ins should work together, I’m going to include the fix with high priority in the next release.

    Much obliged,
    Alex

    Thread Starter melanubis

    (@melanubis)

    Many thanks !! that would be great , currently translating the plugin to Spanish ill send you the files in case you are interested
    Best regards

    Plugin Author Alexandru BOIA

    (@alexandruboia)

    Thank you so much! I’d really like to have a broader language support. I’m not sure if it’s any help, but I have some gdrive spreadhseet readily available for language input: https://docs.google.com/spreadsheets/d/1T6DFQClzQPyqhGQznYSTSama1j95vOGU2PrDsQa6URU/ and https://docs.google.com/spreadsheets/d/1BcOzYhr83UCpm2yB4VhZuhb0wbknhGD4oCR2u5B94iA for the lookup data items.
    And just in case you’re interested on the project’s roadmap for the upcoming version, it’s available here: https://github.com/alexboia/WP-Trip-Summary/issues.

    Regards,
    Alex.

    Plugin Author Alexandru BOIA

    (@alexandruboia)

    Hi melanubis,

    Version 0.2.5 is out now and can now run side-by-side with Waymark.

    Regards,
    Alex.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Can’t see the form on any post’ is closed to new replies.