Support » Fixing WordPress » Can’t see text in content editor (visual or text)

  • Resolved mococa

    (@mococa)


    Can’t see text in the editing block (unless I highlight it), no toolbar. I notice there were changes to TinyMCE with the 4.8 update, but I’m not sure what to do to work with that.

    Just updated WP to the latest, deactivated all plugins, changed to 2016 theme, tried two different browsers (Safari & Firefox), and script debug did not fix the problem.

    Safari browser error console says “Can’t find variable: tinymce. Global Code post.php:1943”

    Firefox browser error says “Reference error: tinymce is not defined. post.php:1943:1

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    I’ve tried everything. Disabled all plugins, switched themes, and replaced all files via FTP. Nothing has worked, and the visual editor is still blank!

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file just below the define('DB_HOST' line.

    To do so, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and edit the file with a plain text editor.

    https://codex.wordpress.org/Editing_wp-config.php#Disable_Javascript_Concatenation

    I have the same problem and adding the line to wp-config.php didn’t make any changes…

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Ok, next please make sure that your browser is up to date by visiting https://whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    Yes! Adding that line of code fixed it for me! Thank you very much!!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.