WordPress.org

Support

Support » Plugins and Hacks » [Resolved] cant see sharing buttons on my events calendar/pages

[Resolved] cant see sharing buttons on my events calendar/pages

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Jeremy Herve

    @jeherve

    I’m afraid I’m not too familiar with the Events Calendar plugin. Did you create a new template file to display events on your site?

    If so, you could add the following code where you want the buttons to appear:

    <?php echo sharing_display(); ?>

    Let me know if it helps.

    i am using my normal front page template i user everywhere else on my site (where the sharing displays fine)

    Plugin Author Jeremy Herve

    @jeherve

    I checked the Events Calendar plugin, and it seems to create its own custom template to display events.

    Luckily, it seems they also added a filter, tribe_events_after_html, allowing you to hook additional elements after the event content.
    I believe you could hook the sharing buttons into that filter, like so:

    function tweakecp_add_jpshare( $after ) {
    
    	if ( function_exists( 'sharing_display' ) ) {
    		$shares = sharing_display( '', true );
    	}
    
    	$after .= $shares;
    
    	echo $after;
    }
    add_filter( 'tribe_events_after_html', 'tweakecp_add_jpshare' );

    Now, I haven’t tested this code but it should work.

    If it doesn’t, you might want to get in touch with the Event Calendar plugin authors, and ask them how to work with that filter.

    You can post there to get some help with their plugin:
    http://wordpress.org/support/plugin/the-events-calendar

    Let me know if it helps.

    that worked a treat for the individual events but not the overall calendar.. but its a great start! i will take up the overall calandar view with the guys at modern tribe..

    thanks for your prompt help!

    Plugin Author Jeremy Herve

    @jeherve

    Good, that’s a start indeed. I had another look at the plugin files, but couldn’t find the template used for the overall calendar. Would you mind pointing me to the thread you open with the Modern Tribe folks, so I can follow along and learn in the process?

    P.S.: nice username, by the way. I’m a fan of the Dark Tower series. 🙂

    THANKEE SAI!!!

    https://tri.be/support/forums/topic/jetpack-sharing-w-events-calendar/

    not sure if you can see it without being a paying customer though.. let me know. if not i am happy to post my findings here

    reply from modern tribe:

    I’m not sure what’s going on there, but a couple of points come to mind.
    •Ideally you should return from your filter function, rather than echoing

    •I can only guess that sharing_display() is returning an empty string (or, for some reason, hasn’t been defined) on those views where it isn’t working, as the filter function itself certainly ought to be running … I’m afraid you would need to dig into Jetpack’s code or reach out to the authors again to work out which of those might be happening and why

    Plugin Author Jeremy Herve

    @jeherve

    I can only guess that sharing_display() is returning an empty string (or, for some reason, hasn’t been defined) on those views where it isn’t working, as the filter function itself certainly ought to be running

    I assume this means that the tribe_events_after_html filter is also used on the overall calendar view.

    Could you go to Settings > Sharing again, and make sure that the buttons are set to appear everywhere (on Posts, Pages, Events, Archive Pages, Home page)?

    If that doesn’t help, could you try using the test function given by the Modern Tribe support folks here:
    http://pastebin.com/b2iEU4Jx

    When you add that function, do you see “Jetpack’s sharing_display() function has not been defined” on the overall calendar page?

    i see the following:

    sharing_display() is not returning anything

    Plugin Author Jeremy Herve

    @jeherve

    Alright. And are all the boxes checked under Settings > Sharing?

    yep!

    Plugin Author Jeremy Herve

    @jeherve

    Thanks for bearing with me.

    Could you open the page where the overall calendar is displayed in your editor, and look for the sharing module below the editor? You’ll want to make sure that Sharing is enabled there.
    http://en.support.files.wordpress.com/2010/08/post_sharing.png

    If you don’t see the Sharing module, click on the “Screen Options” tab in the top right corner of the page, and enable Sharing.

    Let me know if it helps.

    thats just the thing, the plugin does not ‘sit’ on any page so i cannot edit that page as you asked

    the events plugin only allows you to name the slug where the calendar can be seen.
    ie. domainname.com/events

    Plugin Author Jeremy Herve

    @jeherve

    I see. It might be a conflict with the 2 plugins. I will do some more tests, and I’ll get back to you as soon as I have some news.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘[Resolved] cant see sharing buttons on my events calendar/pages’ is closed to new replies.