WordPress.org

Support

Support » Localhost Installs » [Resolved] Can't see post on localhost, but can see in WordPress interface

[Resolved] Can't see post on localhost, but can see in WordPress interface

  • Hi,
    I have an existing blog with many posts and I wanted to work on editing a new theme offline. So, I installed a WordPress locally (and PHP/MySQL using MAMP), on a Mac. I also copied my database from the “live” version of the blog. When I’m in the WordPress interface (the local version), I am able to see the posts, but I can’t see them when I try to view them through a browser (FireFox). I am trying to access it through http://localhost/wordpress/ and I see nothing.
    I installed the WordPress in the following directory: Applications/MAMP/htdocs/wordpress
    I edited the wp_config.php file to point to the database, and added “define(‘WP_HOME’,’http://localhost/wordpress’);
    define(‘WP_SITEURL’,’http://localhost/wordpress’);” as per one of the tutorials (but I also edited these fields in the database through phpMyAdmin.

    What am I missing?
    Any help is greatly appreciated.

Viewing 1 replies (of 1 total)
  • Sorry, it seems that my themes weren’t properly working. Even though they were physically in the right area, WordPress didn’t see them and I had to re-install them. After doing that, I can see the pages.

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Can't see post on localhost, but can see in WordPress interface’ is closed to new replies.
Skip to toolbar