WordPress.org

Forums

[resolved] Can't see or edit Content of Pages and Posts (12 posts)

  1. jimfelder
    Member
    Posted 1 year ago #

    The content is there that was created previously, but now I can't edit the pages or posts. Int the dashboard, the content area is blank, but it's there when you just select all in the browser window. I've turned off plugins, changed to default theme, probably some other things. I'm at a loss.

    http://www.jimfelder.com

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    A) Deactivate plugins.
    B) If not that, try a manual update (leave plugins off).
    C) If not that, all that is left is your commercial theme, consult them (or test with default unedited theme).

  3. jimfelder
    Member
    Posted 1 year ago #

    manual update of what?

    I tried default theme.

  4. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Did you deactivate all plugins and switch to default theme, logout, clear browser cache, login, and test the editor?

  5. jimfelder
    Member
    Posted 1 year ago #

    yes, even tried chrome and firefox.
    Even reuploaded the theme files.

  6. jimfelder
    Member
    Posted 1 year ago #

    also didn't mention that the toolbar at the top is also gone. When I switch to Text tab (html), nothing there either. Must be a WP issue? What file would I upload of WP to try to fix this?

  7. WPyogi
    Forum Moderator
    Posted 1 year ago #

    That doesn't look like twentytwelve with no plugins...

  8. jimfelder
    Member
    Posted 1 year ago #

    well, that's because I put it back. doing all that didn't work so I'm back to what it was. I'm wondering if it's a javascript issue. but I don't know what to do.

    I thought this line was interesting. But not sure if it means anything or if that is even an issue.

    <div id="wp-content-editor-tools" class="wp-editor-tools hide-if-no-js"

  9. WPyogi
    Forum Moderator
    Posted 1 year ago #

    Yes, it may well be a JS issue. You can check for those:

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

  10. jimfelder
    Member
    Posted 1 year ago #

    When I turn on debug mode, the content shows up but this shows at top of window:

    Notice: add_custom_background is deprecated since version 3.4! Use add_theme_support( 'custom-background', $args ) instead. in /home3/jimfelde/public_html/wp-includes/functions.php on line 2839

    I can find this but not sure what to do with it.

  11. Muhammad Haroon
    Member
    Posted 1 year ago #

    Well, try updating your Permalinks once by going Settings > Permalinks. This will regenerate your blog's .htaccess file.

    Hope this will work.

    Muhammad Haroon

  12. jimfelder
    Member
    Posted 1 year ago #

    I actually used the Firefox error console and looked where the errors were so I replaced my wp-includes folder. One file didn't allow me to replace it so it but it fixed my issue. Couldn't even tell you what it was but it worked.

    Thank you for the help. Much appreciated.

    Have a super day!

    Jim

Topic Closed

This topic has been closed to new replies.

About this Topic