Support » Fixing WordPress » Cant see my images in the media library

  • Hi everyone,

    I’m facing a very strange issue in wordpress 4.9. I have quite a few images in my media library however when I choose an image the media library is completely blank.

    On my admin page when I go to the media tab and switch to a list view I can see all the images just fine.

    Furthermore examine the console reveals no errors instead admin-ajax.php gives me a successful response with the id and url of all the images within my library. Despite that nothing shows up on my media screen. It remains completely blank.

    Has anyone else faced a similar issue. What can I do to correctly diagnose and fix this error?

    Thanks,
    Akshat

Viewing 15 replies - 1 through 15 (of 18 total)
  • Same for me.

    https://core.trac.wordpress.org/ticket/42574

    • This reply was modified 2 months, 3 weeks ago by  edzuslv.

    Thanks @edzuslv for linking to the issue. But I’m not getting any error in the console. Are you also getting errors in the console?

    No errors just blank Media and only for one site. I also tried some patches from trac I linked but they don’t seem to work.

    Hi all,

    If you’re not seeing any JS errors in your browser’s console it’s not likely that your experiencing the same issue described in 42574. Could you take a look at your network panel and see if you have any server errors when you try to load the medial library? Also, does the same issue happen in the media library on list and grid view, or only the grid view?

    Thank you @joemcgill for the pointers!

    Unfortunately I get no server errors. At least nothing is logged into my nginx error log files. The issue only happens on the grid view. The list view works fine for the most part but when I click on “attach image” link the resulting dialog window is empty. That is nothing actually happens. I get no list of posts to attach the image to.

    I have inspected the network requests in my console and it seems that the server returns the results. The admin-ajax.php request successfully executes. I can see 200 Ok status code as well as the JSON data returned for all my images. But nothing is rendered on the screen and the spinner in the grid view keeps on spinning.

    A similar problem occurs when I’m uploading images. The response from the UI is that image can’t be uploaded but the image is actually uploaded to the server.

    For me things are even worse. 😀
    1) After update to 4.9 it still says I’m not updated even if I manually replace files.
    2) Media gallery is black and Insert media un post are blank too.
    3) My admin account says I don’t have privileges to disable plugins even my admin rights are ok. I checked them in database. Added another admin user and that one can’t deactivate also.

    Regarding the plugins. I had that problem as well. Didn’t report it here because I didn’t think that they were relevant to this issue. Also I managed to delete them manually using wp-cli. Right now I’m trying to set up a wp 4.9 container to see if I can replicate the issues on my dev machine.

    But its good to know that I’m not the only one facing these problems 🙂 BTW have you tried to check if these issues persist in a fresh 4.9 install?

    I didn’t but I have another web where everything mentioned works fine. Update went ok, media works and no problems with admin.
    Also one other had problems with theme edit and its also 4.9 bug, he just did rollback to 4.8.3.

    I can confirm that this issue occurs on a fresh wp install. It might be a bug. Can you guys please confirm this? Also do you think that this is an extension of the bug linked here or this should be a separate issue altogether?

    I see 2 errors in console when I open Media:
    https://i.imgur.com/XFFkIDk.png

    Edit: Just did a rollback to 4.8.3 and everything works again.

    • This reply was modified 2 months, 3 weeks ago by  edzuslv.

    Is it fixed for you in 4.9.1?

    Thanks for asking @edzuslv. The problem is not fixed for me on the production. I’ll report back if I see any fixes on the test setup I created. Is it fixed for you?

    EDIT: I can confirm that the problem is also not fixed for the test deployment on 4.9.1

    • This reply was modified 2 months, 2 weeks ago by  akshatjiwan.
    • This reply was modified 2 months, 2 weeks ago by  akshatjiwan.

    Mine is fucked up completely when I upgrade. 😀

    1) Media broken
    2) Admin user looses some permissions like activate/deactivate plugins
    3) It suggests to upgrade again even if it says it upgraded successfully. Manual upgrade also doesnt change that. In admin it still shows that upgrade to 4.9.1 available.

    Sorry to hear that…Unfortunately I have no solution to offer. What has worked for me however is that I was able to back up my database and do a fresh install for wp. If you backup wp database and files downgrading might help….

    Also have you managed to replicate the issues on a dev server? If nothing else it could give you an idea of where things are broken. On my fresh install at least I don’t have any issues related to admin user so its quite possible that the problem might be related to some plugin that you have.

    BTW you can also delete plugins with the help of wp cli command line tool. Have you tired that? It can come in handy in times like this.

    Best,
    Akshat

    I downgraded already and staying downgraded for now.

    I tried many ways also with all disabled plugins. No idea how it just cant upgrade if I do it manually. They fucked up some shit with this update. I`m using wordpress for years and never expierienced such things.

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.