Support » Plugin: CKEditor WYSIWYG for Gravity Forms » Can’t see in Chrome

  • Resolved apfotos

    (@apfotos)


    The editor displays fine in Firefox and Safari but can’t see it in Chrome. I’m using the latest Chrome browser

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author ovann86

    (@ovann86)

    Hey,

    I’m seeing the editor load on my demo site using Chrome 55.0.2883.87 m

    Can you confirm if you’re having the same problem when viewing the demo website?

    http://demo.itsupportguides.com/gravity-forms-wysiwyg-ckeditor/multi-page-form/

    Usually when the editor doesn’t load it’s because there’s been a JavaScript error at some point before it loads.

    To check for errors, in chrome, can you

    1. open up the debug tool by hitting F12 on your keyboard
    2. Open the ‘console’ tab
    3. reload the form with the ckeditor enabled field
    4. check for any error messages and let me know. For example ‘ x does not exist’ or ‘error on line x’

    It works now – it must have been a cached page I was looking at. Thanks for checking it out.

    Gravity forms 2.0 incorporated its own WYSIWYG for parapraph fields. At this point WYSIWYG CKeditor stopped working. I needed insert table button, and upload image button, which the incorporated in GF 2.0 doesn’t have.
    Any way of being able to use again WYSIWYG CKeditor? Thank you

    Plugin Author ovann86

    (@ovann86)

    Hey,

    Im not having any issues with using this plugin in Google Chrome, but if you have doubts check the demo page?

    https://demo.itsupportguides.com/gravity-forms-wysiwyg-ckeditor/multi-page-form/

    apfotos mentioned caching – if you’re behind internet proxy infrastructure (usually if you’re on a school or work network)- perhaps it’s caching there? Or perhaps your Chrome is being extra-cachey ? (if such a thing exists). Try refreshing using F5 or try another computer?

    Exactly what isn’t working? Does CKEditor fail to load at all?

    Do you know how to debug a browser? – Hit f12 on your keyboard – a debug console should appear at the bottom or right of the window, reload the page with ckeditor, then look for a ‘console’ tab in the debug control, hopefully there will be some error messages in there that’ll help. e.g. ‘error at line 1 in x.js’ (if you get this far and see an error i would reload the page with ?gform_debug at the end of the URL – then repeat – this will give a better error message, e.g. ‘error at line 25’.

    Failing this, can you send me a link to a page that I can see it not working in?

    RE: CKEditor VS native WYSIWYG (which is TinyMCE in WordPress) – I would use CKEditor hands down – I’m not a fan of TinyMCE by any means.

    • This reply was modified 2 years, 10 months ago by ovann86.

    I also have problems with CKEditor not loading in Gravity Forms. It worked a few days ago so I suspect that something happened when I updated to 1.10.1.

    So I did the above suggested tests and in the Console I got this:
    Uncaught Error: [CKEDITOR.resourceManager.load] Resource name "widgetselection" was not found at

    and then the URL to the plugin:
    ... /wp-content/plugins/gravity-forms-wysiwyg-ckeditor/ckeditor/plugins/widgetselection/plugin.js?t=GB8C where I excluded our server address, which I checked and it is correct. What is not correct is the path to the “plugin.js”, for me it is:
    /wp-content/plugins/gravity-forms-wysiwyg-ckeditor/ckeditor/plugins/widget/plugin.js so it’s “widget” instead of “widgetselection”.

    If I then copy the “widget”-folder to a “widgetselection”-folder I get a different error message:

    Uncaught Error: [CKEDITOR.resourceManager.add] The resource name "widget" is already registered.
        at CKEDITOR.resourceManager.add (ckeditor.js?ver=1.10.1:247)
        at plugin.js?t=GB8C:15
        at plugin.js?t=GB8C:3647

    Which makes sense since it’s the same “plugin.js”-file.

    and I also get the error message:

    Uncaught TypeError: Cannot read property 'icons' of null
        at CKEDITOR.resourceManager.<anonymous> (ckeditor.js?ver=1.10.1:250)
        at CKEDITOR.resourceManager.<anonymous> (ckeditor.js?ver=1.10.1:249)
        at f (ckeditor.js?ver=1.10.1:244)
        at Array.C (ckeditor.js?ver=1.10.1:244)
        at u (ckeditor.js?ver=1.10.1:244)
        at ckeditor.js?ver=1.10.1:245

    If I Deactivate the CKEditor plugin I can of course use the standard GF Editor in the Form, so this is now our work around.

    The Demo URL above works so I guess it is something locally, but what and why?

    Any ideas?

    Thank you in advance …

    Plugin Author ovann86

    (@ovann86)

    @mrasker – that’s really helpful thanks.

    I’m not exactly what widgetselection is meant for or why it’s expected suddenly … but it appears to be a separate plugin, in addition to ‘widget’.

    It sounds like you have access to the files/folders on the server (e.g. FTP access).

    Can you rename the ‘widget’ folder back to ‘widget’ and download and add ‘widgetselection’ from here

    http://ckeditor.com/addon/widgetselection

    Then reload the CKEditor page and see if it loads or another message appears.

    Thank you for the very quick reply!

    Yes, I have root access to our WP server.

    So:
    – I DL the above plugin, and all of the 11 dependency plugins
    – Copied the content of all the zip:s to the …/plugin/-folder so I now have total of 39 folders/plugins
    – Edited the config.js to include all the added plugins and noticed that the already existing 28 plugins are not activated in this file so where are they activated?
    – Deactivated the CKEditor-plugin (and later also GF) in WP
    – Activated the CKEditor-plugin again (and later then also GF)
    – Reloaded the page with the GF-form with the CKEditor enabled

    and got this:

    Uncaught Error: [CKEDITOR.resourceManager.add] The resource name "widget" is already registered.
        at CKEDITOR.resourceManager.add (ckeditor.js?ver=1.10.1:247)
        at plugin.js?t=GB8C:15
        at plugin.js?t=GB8C:3647

    and I also got this:

    Uncaught TypeError: Cannot read property 'icons' of null
        at CKEDITOR.resourceManager.<anonymous> (ckeditor.js?ver=1.10.1:250)
        at CKEDITOR.resourceManager.<anonymous> (ckeditor.js?ver=1.10.1:249)
        at f (ckeditor.js?ver=1.10.1:244)
        at Array.C (ckeditor.js?ver=1.10.1:244)
        at u (ckeditor.js?ver=1.10.1:244)
        at ckeditor.js?ver=1.10.1:245
    (anonymous) @ ckeditor.js?ver=1.10.1:250
    (anonymous) @ ckeditor.js?ver=1.10.1:249
    f @ ckeditor.js?ver=1.10.1:244
    C @ ckeditor.js?ver=1.10.1:244
    u @ ckeditor.js?ver=1.10.1:244
    (anonymous) @ ckeditor.js?ver=1.10.1:245

    So then I Edited the config.js again and remove the line with: config.extraPlugins = 'widget'; and reloaded CKE and GF (just to be sure) but it made no difference. Bummer …

    I have checked the “Installation Status” and everything is Green, but I still want to mention that we are on WP 4.6.1, PHP 5.4.16, MariaDB 5.5.52 and GF 2.1.2. We can not upgrade to WP 4.7 since one of our critical plugings do not support it, yet.

    Any other ideas?

    Thank you in advance

    Plugin Author ovann86

    (@ovann86)

    OK, so just looking through the widget plugin I see it now lists widgetselection as a requirement (although the website for the plugin doesnt mention this …) – and this requirement started to affect this plugin from version 1.10.0.

    So what I will try to do is add it in from this end, retest and push out an update.

    With your question on how it includes the plugins – most (except for five?) of the plugins are ‘core’ and don’t need to be specified, just need to be in the ‘plugins’ directory. With the additional ones, they’re not added into the config.js file in the ckeditor folder – they’re added into the ‘itsg_gf_ckeditor.js’ through a localised string (so the plugin, from the server using PHP creates a list of which ones are needed and passes it through to the JavaScript for when the plugin loads) … not the best description, but in short the list of plugins to activate (that arent core) come from gf-wysiwyg-ckeditor-addon.php under the ‘localize_scripts’ function.

    Plugin Author ovann86

    (@ovann86)

    Just one question, before I push out an update – did you have the OEMBED plugin/option enabled?

    Plugin Author ovann86

    (@ovann86)

    OK I have to leave now but I’ve tested and released 10.1.2 – hopefully it works.

    I was able to reproduce the same non-loading issue by enabling the oembed option and then confirm it working with the updates. So hopefully it also works for you.

    I have a folder called oembed but I’m not sure I have it enabled or not. How can I check?

    I just checked for updated WP Plugins but 10.1.2 is not yet in the list. Maybe it will be tomorrow so will check again and report back.

    Thank you again for the very quick turn-around!

    I still can not see the 10.1.2, but maybe it will take a few days?

    At your convenience I also would like to know how to check if a Plugin is Enabled or not.

    Hi, any update on this?

    Plugin Author ovann86

    (@ovann86)

    RE: version 10.1.2

    I didn’t update the version number in one spot, resulting in it not appearing in the updates list.

    I’ve fixed that now so it should come up in the next 15 minutes.

    Hopefully that sorts out the load issue.

    RE: list active plugins.

    Run

    CKEDITOR.plugins.loaded

    In your browsers console (f12 on your keyboard will open it).

    This will list all the additional plugins – not the standard ones you see in the toolbar, for example the ‘bold’ button etc.

    Tjoho! We are back in business. 🙂

    Thank you for the excellent support.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can’t see in Chrome’ is closed to new replies.