Support » Plugin: Easy Google Fonts » Can't see Google fonts under Font Family

  • Resolved saratorge

    (@saratorge)


    Hi!

    I’ve installed and activated the Easy Google Font plugin. People say it is fantastic and oh so easy, but I (and my colleagues) feel so stupid right now… 🙂 I can’t see any Foogle fonts in the drop down list under “Font Family”.

    What have I done wrong? Is there anythong else that should be activated before we can start working with this plugin?

    We have watched this movie a thousand times now, but at 01:55 I am so lost. Can only see the Standard Web Fonts.

    What to do?

    Thank you so much!

    https://wordpress.org/plugins/easy-google-fonts/

Viewing 9 replies - 1 through 9 (of 9 total)
  • PS.

    – With “this movie” I mean this one: http://vimeo.com/77878709

    – We use the theme Avada.

    Plugin Author Sunny Johal

    (@sunny_johal)

    Hi saratorge,
    It’s likely that the server that you are hosting your website doesn’t allow your site to read the local fonts file that comes with this plugin. I recommend that you get a google api key, that should solve your issue. Follow these instructions and you should be good. Also, please note that in order to use this plugin you should have some basic knowledge of your themes css selectors. Let me know how you get on. Cheers

    Sunny

    Hi!

    We did as you said and yay! – we can now see the Google fonts in the menu. Thanks!

    But… New problems turned up. Although choosing new fonts and colors etc in the menu, they won’t show up in the preview and not on the real site either.

    Any more suggestions what to do?

    Cheers
    Sara

    Oh, I forgot to say that it works with Paragraphs but not for Headings!
    /Sara

    Plugin Author Sunny Johal

    (@sunny_johal)

    Hi Sara,
    You just need to add the appropriate font controls and css selectors (by going to Setting > Google Fonts). Generally speaking to get the most out of this plugin you need to have knowledge of your themes CSS selectors. If you do not have this knowledge then any basic developer should be able to give you a hand with it. Let me know how you get on. Cheers

    Sunny

    It seems like I’m experiencing the same issue as Saratorge.

    I’ve installed the plugin, gone through the video, and in my drop down, all I am able to see are the standard web fonts, not the google fonts.

    I walked myself through the options to issue credentials for the web fonts api here:

    http://screencast.com/t/cdmFZJcCAmF0 and that seems to be working fine.

    For kicks I also regenerated my key in case the first one was borked in some fashion.

    The plugin works great on the standard web fonts, but I can’t get it to load googles web fonts at all.

    Plugin Author Sunny Johal

    (@sunny_johal)

    Hi radstu,
    Have you turned on the web fonts developer api in the developer console? Try following these instructions:

    1. Visit https://console.developers.google.com and sign into your google account.
    2. Click Create Project and click the create button.
    3. Click into your new project and select API’s on the left hand menu.
    4. Turn on Web Fonts Developer API.
    5. Once this is enabled do the following:
    1. Click the Credentials menu item underneath the APIs & auth menu on the left hand site
    2. Click the create new key button.
    3. Select browser key
    4. Leave the box empty and just click create.
    5. Paste the api key into the settings page and click the save button

    Let me know how you get on. Cheers

    Sunny

    Thank you.

    I thought that I had enabled the Web Fonts Developer API, but when I logged in, I observed it was off.

    I also noticed: http://screencast.com/t/TFRSalRch36R … it seems like my connection requests are reaching google, although I can’t yet locate where to find out details about the errors specifically.

    I’ve double checked the rest of those settings relating to the credentials, and those are still all working as noted in my earlier post: http://screencast.com/t/cdmFZJcCAmF0

    This morning as I tested, things were not working. However, now that I’ve gone through and re-saved everything at google and also over on WordPress, I’m now seeing the following message on worpdress that was missing before:

    Your Google API Key is valid and automatic font updates are enabled.

    Further tests show it’s working now as expected, so everything is resolved. Thank you for your help!

    Plugin Author Sunny Johal

    (@sunny_johal)

    Hi radstu,
    Great, I’ll mark this issue as resolved. I was wondering if you could rate this plugin when you get a moment please. Cheers

    Sunny

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can't see Google fonts under Font Family’ is closed to new replies.