WordPress.org

Support

Support » How-To and Troubleshooting » Can’t search if the word begins with letter d

Can’t search if the word begins with letter d

  • This is so frickin weird. The search feature works fine, unless the word begins with the letter d. Every other letter of the alphabet works fine.

    The site is http://thatcostumegirl.com and the current version is 2.3.3. If you go to this site, try searching.

    Any ideas why the letter d is so evil?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Congrats on one of the most strange WP problems I have ever heard of!

    I just tried your blog, and it’s like you said. Search for “dino” and it hangs. Every other search returns results quickly. What is the deal?? Sorry I don’t have an answer. I will think on it.

    I guess my suggestion is Deactivate all your plugins, and try the search again. Tell us if it works then.

    Oh P.S. you should really consider upgrading to WP 2.6+. There have been many features and security added since the 2.3 days.

    I deactivated all plugins and still encountered this problem. Very strange!

    I will look into upgrading to 2.6+.

    In the meantime, if anyone has any ideas, I’d love to hear them.

    Well I haven’t fixed this problem, but I did find a hack around to make things work.

    After lots of playing around, I noticed:

    http://thatcostumegirl.com/?s=dog doesn’t work but

    http://thatcostumegirl.com/page/1?s=dog DOES work for some reason.

    So I just added /page/1 to the searchform code, so now it reads:
    action=”<?php bloginfo(‘url’); ?>/page/1″

    And it works! Good enough for me. But I still have no idea what caused the problem in the first place. My best guess at that when she refers to the Dragon Con convention as D*C, somewhere that asterisk broke something. Though I tried adding asterisks to different letters in the title, body and tags, I was unable to break another letter and repeat the original problem. But hey, at least searching works.

    Chalking this one up in the “weird WordPress problems” list (if there is such a list)

    Happy to hear you found a workaround.

    I am running wordpress 2.7 – fresh brand new clean install, no plugins (no posts except the default even!) and I’m having this same problem.

    http://wordpress.org/support/topic/232155?replies=2

    That’s crazy! How bizarre.

    Make that a third person, I am getting this error right now also. Checked my entire database, nothing wrong or any corrupt values.

    Hey, we’ve also discovered the same problem on our blog. What could explain this? Weird and annoying, try it here:

    http://www.wreckthetapedeck.com/

    I’d rather not change the searchform code to add /page/1… any suggestions??

    Any update on this? I am having a similar problem… Search works fine for single words. Searches for multiple terms result in a 400 error!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t search if the word begins with letter d’ is closed to new replies.