Support » Fixing WordPress » Can't search for/add plugins can't resolve external hosts

  • Hi,
    I think this is probably a DNS configuration issue with my host, but as they’re denying all fallibility I might as well post here… just in case.

    For a couple of weeks, both the WP sites that i’ve done have lost some functionality. When I try to search for plugins I receive an error that says –

    “An unexpected error occurred. Something may be wrong with or this server’s configuration. If you continue to have problems, please try the support forums.”

    And when I’m in the dashboard, ‘Incoming Links’ and ‘WordPress Blog’ say things like –
    RSS Error: WP HTTP Error: Couldn’t resolve host ‘’

    I’ve looked around and found all sorts of reasons for such errors, with different people blaming each other, and think i’ve tried all the solutions on offer –

    Change theme.
    Deactivate plugins, then back one at a time.
    Fresh download and write over all but ‘wp-content’ etc.


    So I thought i’d come here for the first time, before amping it up with my host.
    (It really does feel like a DNS configuration issue…)
    Here’s one of the sites affected, just in case that’ll help in any way –


Viewing 10 replies - 1 through 10 (of 10 total)
  • It really does feel like a DNS configuration issue…

    I agree. ‘Couldn’t resolve host’ definitely suggests a DNS problem.

    Hi esmi,
    Yup, that phrase was the reason that I originally thought it was something to do with them. Which they denied.
    I’ve now gone back to them and said (apologies to Otto, whose post I paraphrased, due to a technical lack on my part) –

    “I’m pretty sure you’re checking the wrong thing. This has nothing to do with the VPS or the sites working.

    It has to do with the DNS configuration on the web server. The web server is trying to make an outgoing connection to the internet, and the DNS on the web server is NOT configured correctly, so it can’t resolve the IP of

    Try to telnet or ssh to the web server, and then ping the outside world from there. I’m betting you won’t be able to do it, because name resolution is not setup properly.

    The issue is related to the fact that the server can’t figure out the IP address given the host name of the site it’s trying to connect to.”

    Staggeringly, they’ve responded with this –

    “I am not sure what you’re explaining here. Can you please let us know the domain that is not working.

    The service named (DNS) is working fine on your VPS.”

    I’m just about to respond, but was wondering whether you, or anyone else here, have any helpful (and polite… unfortunately) words or phrases I could use to further getting my problem resolved?

    (Can’t help but notice that this tech department doesn’t seem very tech. Even though it’s a proper VPS with a big company etc.)


    Have you sent them copies of your error messages?

    Oh yes. They were the first things I sent…

    Tell them that their DNS is broken. It cannot resolve

    I’ve told them that (in no uncertain terms).
    They deny it.
    Anyway, as it seems that this issue has nothing to do with wordpress, I’ll take my mounting frustration and anger elsewhere.
    Thanks for your help anyway!

    Did you find a solution?, I have the exact same problem:)

    I have the same problem also. Who is your host? Any solution yet?

    hi has this ever been solved?
    i have the same problem with a brand new server i have installed
    centos – plesk panel

    this is not the first plesk panel server i run and this happens to all sites on this specific VPS

    if i run the site a apache module (php) – i can search for plugins but this is not recommended for security issues

    if i run the site as php-cgi or fast cgi i get the same error

    this is frustrating and its not a dns issue but a module or compilation error in the server side

    please if anyone found the reason or the responsible php config or module
    i am desperate
    been 5 hours of testing stuff and no luck
    nothing in the website logs as well

    found out the problem
    it was IPTABLES
    once it was stopped everything started working
    i dont need it because i protect my servers with very strong firewalls and IPS
    so for me problem solved

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can't search for/add plugins can't resolve external hosts’ is closed to new replies.