Support » Fixing WordPress » Can’t save widgets settings…

  • quarky


    Just upgraded from 2.1 to 2.3
    I’ve removed old widgets plugins and installed up-to-date ones…
    But when I change anything on the Widgers page in admin panel it seems like it’s not saving any data into DB. So no changes in the site view and when I click “Widgets” again – everything looks like I’ve never touvhed it…

Viewing 10 replies - 1 through 10 (of 10 total)
  • MichaelH


    I can’t find it, but belive I read someone with this problem solved the issue by deleting and reuploading the WordPress files.

    Steps 7 and 8 of Upgrading_WordPress_Extended explain that.



    It’s not helping…



    I guess I should digg the code…

    Adam Brown


    I came across this while developing my own widget a while back. It turned out the widget was generating a PHP error, which was cutting off WP’s processing of my saved changes. But for whatever reason, the PHP error message was showing up in the HTML source but not on the screen, I don’t remember why. There are other things that could cause this, but it’s possible one of your widgets is causing a similar error. So just to check:

    Go to your widgets editing screen. Make some changes to your widget settings and save them. If they DON’T save (i.e. if this problem persists), view the HTML source. (Check your browser’s Edit and View tabs, depending on which browser you are using, for a “View Page Source” or “Source” option.) Scroll all the way to the end of the HTML source. Does the last line in the source contain an error message, or just normal HTML code? (You don’t need to know HTML to answer this question–if it’s an error message, it should be pretty obvious.)

    If you do have an error message, try disabling your widget plugins one at a time to see which one is causing the error. You’ll probably be able to tell from the error message which widget you need to disable.

    Again, this might not be the problem, but it’s something I’ve run into in the past.



    Am having the same problem with Breukie’s categories widget, though all the rest are saving. Tried adamrbrown’s suggestion, and see no error. This is rather frustrating.



    I’m good in web programming, so I can find the error 🙂
    I just don’t have time to find the function that causes an error.

    Anyway – no errors are generated. It says “Sidebar updated” and all changes are saved (visually, because of $_POST processing). But no changes are in DB…



    My having same prob: I can install, and activate the plug-in but it displayed on the site does not reflect the conditions of the control panel that set in the widget.



    i’m having the same problem. The only difference is when I try to add a widget to the sidebar (i can install them and edit them no problem) and I hit save, it gives me a forbidden error.

    I can’t for the life of me figure it out.

    My problem is fixed! I followed this post

    and created a .htaccess file and uploaded it to my wp-admin wordpress directory and now i have no problems with my widgets!

    I’m having this problem still on wordpress 2.3.1 and I tried the fix as well – but it gave an error. does anyone else have a newer fix to this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t save widgets settings…’ is closed to new replies.