Support » Plugin: MetaSlider » Can’t save slider settings

  • Resolved bigbanks

    (@bigbanks)


    Hi,

    Recently I’ve updated to v3.14.0, and noticed that after creating a new Slide Show I can’t save slideshow settings. I can add new slides to the slideshow, but can’t update their settings as well.

    When I click “save” I see the message of “successfully saved”, however all the settings gone.

    Tested in Firefox / Google Chrome browsers.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi @bigbanks,

    How many slides do you have on this slideshow?

    What if you create a new slideshow. Do the settings work there?

    Hi, @kbat82

    I have 4 slides in that slideshow.

    Yes, I have tried to create one more slideshow, but it still doesn’t work. The same thing with any previously created slideshow.

    Currently turned back to Version 3.7.2, to make “Save” button work.

    I have the same problem..I tried to save the words on the slider, and I hit save and it doesn’t save anything (tried this 20 times or more)..I’m using Version 3.14.0

    Plugin Contributor kbatdorf

    (@kbat82)

    @bigbanks – Might be difficult to debug at this point. Why did you go back to 3.7.2 instead of a more recent version like 3.11? Do you have REST disabled?

    @amweiss98, can you open your own issue? While the symptom might be similar the cause and solution could be completely different. Can you mention any errors you see in the developer tools?

    Dev tools – https://updraftplus.com/faqs/how-do-i-open-my-browsers-developer-tools/

    New post – https://wordpress.org/support/plugin/ml-slider#new-post

    @kbat82

    I’ve turned to 3.7.2, just because I previously use this version and have its backup.
    If you could provide most recent versions for testing, please share a link.

    Yes, I keep REST disabled using a number of actions, because I do not use REST features.

    
    
    add_filter('rest_enabled', '__return_false');
    
    remove_action( 'xmlrpc_rsd_apis',            'rest_output_rsd' );
    remove_action( 'wp_head',                    'rest_output_link_wp_head', 10, 0 );
    remove_action( 'template_redirect',          'rest_output_link_header', 11, 0 );
    remove_action( 'auth_cookie_malformed',      'rest_cookie_collect_status' );
    remove_action( 'auth_cookie_expired',        'rest_cookie_collect_status' );
    remove_action( 'auth_cookie_bad_username',   'rest_cookie_collect_status' );
    remove_action( 'auth_cookie_bad_hash',       'rest_cookie_collect_status' );
    remove_action( 'auth_cookie_valid',          'rest_cookie_collect_status' );
    remove_filter( 'rest_authentication_errors', 'rest_cookie_check_errors', 100 );
    
    remove_action( 'init',          'rest_api_init' );
    remove_action( 'rest_api_init', 'rest_api_default_filters', 10, 1 );
    remove_action( 'parse_request', 'rest_api_loaded' );
    
    remove_action( 'rest_api_init',          'wp_oembed_register_route'              );
    remove_filter( 'rest_pre_serve_request', '_oembed_rest_pre_serve_request', 10, 4 );
    
    

    I just have tried to remove all of this actions from my functions.php,
    Unfortunately seems that it doesn’t make a sense. “Save” still doesn’t work.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @bigbanks

    If you look in ml-slider/admin/Pages.php on line 102 I was experimenting with a second way to ensure rest was enabled as the current test is pretty primitive (just checks if the class exists).

    Can you try to uncomment that line and see if that works? Otherwise, just update the $can_use_rest variable to false and it should switch to admin-ajax.php to handle everything.

    If it works after that I can add it to the next release.

    • This reply was modified 5 months, 3 weeks ago by kbatdorf.

    @kbat82

    Great. Thank you so much.

    Uncommenting line 102 didn’t work, but changing line 99 to:

    $can_use_rest = false;

    solved the problem. Now I can save all the settings.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @bigbanks

    I won’t be able to add that to the next update but I will look into further how to check whether REST is disabled. I might need to provide you with an override specific to MetaSlider.

    WordPress doesn’t really want users to disable REST so rest_enabled filter doesn’t seem to be doing anything (otherwise that would have been a good thing to check for)

    https://core.trac.wordpress.org/ticket/38446

    Plugin Contributor kbatdorf

    (@kbat82)

    I’ll be adding a constant to the next release which will disable REST in MetaSlider. Most likely you won’t have to change anything, since I added a check for that WP filter (even though its deprecated). But if you do, you can add this to wo-config.php or functions.php:

    define('METASLIDER_FORCE_ADMIN_AJAX', true);

    Currently it wont do anything as it’s not released yet, so if this changes I will update this post.

    Let me know if you have any questions.

    • This reply was modified 5 months, 2 weeks ago by kbatdorf. Reason: added code block

    Hi @kbat82

    Thank you for the update.

    Actually as I mentioned above, I tried both – with / without ‘rest_enabled’ filter, and it didn’t work in both cases.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @bigbanks

    That filter actually doesn’t do anything anymore in recent versions of WP, but I still wrote a check to see if it’s being used. Anyway, if the plugin breaks after the update, you should be okay by adding the constant I mentioned.

    Hi @kbat82

    Got it, thank you. I will use this constant in my projects.

    rmob1978

    (@rmob1978)

    hi! same issue here, I cannot save anything, save button keeps turning forever….
    I am using version v3.14.0
    what can I do?
    thanks

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @rmob1978

    It’s better to open your own issue and refer to other issues if needed so that others aren’t emailed every time and typically the solutions are not the same although the symptoms might be similar.

    https://wordpress.org/support/plugin/ml-slider#new-post

    Can you mention any errors you see in the developer tools?

    https://updraftplus.com/faqs/how-do-i-open-my-browsers-developer-tools/

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Can’t save slider settings’ is closed to new replies.